summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 21:48:48 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 22:06:06 +0200
commit7539bb3dce88b35adb7047a2e2b2b291205bd12a (patch)
tree2064dab14f30be61c0790fdcb4c5ea0667985f79
parentdev-python/elementpath: add 2.5.0 (diff)
downloadgentoo-7539bb3d.tar.gz
gentoo-7539bb3d.tar.bz2
gentoo-7539bb3d.zip
dev-python/sqlitedict: add 2.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sqlitedict/Manifest1
-rw-r--r--dev-python/sqlitedict/sqlitedict-2.0.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sqlitedict/Manifest b/dev-python/sqlitedict/Manifest
index 2185fa213e44..dcc5d2fe7475 100644
--- a/dev-python/sqlitedict/Manifest
+++ b/dev-python/sqlitedict/Manifest
@@ -1 +1,2 @@
DIST sqlitedict-1.7.0.tar.gz 28234 BLAKE2B f67187ee27acbe5525b5f0efb8fd85b68e820439e273af8f9ac4e2f223a2c267f252cb0d60366bd51ba9b55cf36d892e02bdfe727a366bfd266005d98d477c9f SHA512 1ef5e0caf81f7ac17eac0d8573c3404ea043c0c5700fe6b4b9f28ac86ad8d97416bad561318898967cf1af0d7e616684ee3044018e24dab3686d43554c74fef1
+DIST sqlitedict-2.0.0.tar.gz 46266 BLAKE2B c320c5b61e535ff668462fc079cd501e8aae4fb334230ed0b9c5eae0c53f569c8971a8484cddf85575b1e2d28b051d2f0fa8376a1176e3116a1a0516e36202aa SHA512 3ba84676680e5e9408804618e4ae871d09fcfdc999f06c1143f42329059e6033abb2d897ed485d9d84dc2761032fa07f00f08b259f1d9e6426c4ee0068446ed8
diff --git a/dev-python/sqlitedict/sqlitedict-2.0.0.ebuild b/dev-python/sqlitedict/sqlitedict-2.0.0.ebuild
new file mode 100644
index 000000000000..1d9e040051c0
--- /dev/null
+++ b/dev-python/sqlitedict/sqlitedict-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent dict in Python, backed by SQLite and pickle"
+HOMEPAGE="https://github.com/piskvorky/sqlitedict"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_core.py::TablenamesTest::test_tablenames
+ tests/test_onimport.py::SqliteDictPython24Test::test_py24_error
+)