summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-07-02 18:35:56 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-07-02 18:53:59 -0500
commit7546af11691bb50441de296b0c6ad5417d998a8a (patch)
tree69b1f2e46cb27e4f015a3e7fb8577f890b4b3de2
parentdev-python/oslo-upgradecheck: 1.0.1 stable amd64/x86 with cleanup (diff)
downloadgentoo-7546af11691bb50441de296b0c6ad5417d998a8a.tar.gz
gentoo-7546af11691bb50441de296b0c6ad5417d998a8a.tar.bz2
gentoo-7546af11691bb50441de296b0c6ad5417d998a8a.zip
dev-python/oslo-concurrency: 4.0.2 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-3.29.1.ebuild56
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.0.2.ebuild2
3 files changed, 1 insertions, 58 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 19e1dd9dc944..e4542793eb06 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,2 +1 @@
-DIST oslo.concurrency-3.29.1.tar.gz 51785 BLAKE2B 4035981fcff3cb4384209f3b640b928dfacd13e324c9df1dfebb0c5230727736ff803b478e506b08ac4bd7bd405763b93bdb951b01751a5e293daa33df860c8e SHA512 f820b07dbb26be9170c7ded08ce96bebc8c8cbfa72a3be56e0cb0fd7a025160fe630ad256c8c5b1adc9059cd1608c3625513b3da311e5a611866280d2b65424e
DIST oslo.concurrency-4.0.2.tar.gz 53910 BLAKE2B 090d9ba4b5267f63edf6cbc6f585e48019a4ac293e24914a8f7c52009b34ce9a4822a8705934c642663bd2a09be3085458868159ef041498e2085e4ccbec50f9 SHA512 ca1ef615ebe986acac853666877061bbc7a02c09bec294ec6221ae4800a561cf9f218855f7eb8b96184d645924e5c68963b47116835c7d2495de83617439d1ef
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-3.29.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-3.29.1.ebuild
deleted file mode 100644
index 02eb25dc688b..000000000000
--- a/dev-python/oslo-concurrency/oslo-concurrency-3.29.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="library for running multi-thread, multi-process applications"
-HOMEPAGE="https://pypi.org/project/oslo.concurrency/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
-S="${WORKDIR}/oslo.concurrency-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^futures/d' test-requirements.txt || die
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests ${PN/-/_}/tests/ || die "test failed under ${EPYTHON}"
-}
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.0.2.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.0.2.ebuild
index 7d4e1b76c591..6e2470a8637d 100644
--- a/dev-python/oslo-concurrency/oslo-concurrency-4.0.2.ebuild
+++ b/dev-python/oslo-concurrency/oslo-concurrency-4.0.2.ebuild
@@ -13,7 +13,7 @@ S="${WORKDIR}/oslo.concurrency-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE=""
RESTRICT=""