summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-03-08 10:36:30 +0000
committerMarek Szuba <marecki@gentoo.org>2021-03-08 10:44:48 +0000
commit754fd8465bd589b63a735a00efa67084241788be (patch)
tree6481f92a521eea60f55c346643af6d5262192c76
parentdev-python/pillow: Stabilize 8.1.2 ppc, #774387 (diff)
downloadgentoo-754fd8465bd589b63a735a00efa67084241788be.tar.gz
gentoo-754fd8465bd589b63a735a00efa67084241788be.tar.bz2
gentoo-754fd8465bd589b63a735a00efa67084241788be.zip
media-gfx/pngcrush: always use system libs
pngcrush comes with bundled libpng-1.6.32 and zlib-1.2.11. The former is outdated and contains several known security vulnerabilities, the latter causes build failures on some architectures which standalone sys-libs/zlib does support. And why do we need bundled libraries for something like this anyway, especially given it uses two different source tarballs? Closes: https://bugs.gentoo.org/774417 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--media-gfx/pngcrush/Manifest1
-rw-r--r--media-gfx/pngcrush/metadata.xml3
-rw-r--r--media-gfx/pngcrush/pngcrush-1.8.13.ebuild16
3 files changed, 5 insertions, 15 deletions
diff --git a/media-gfx/pngcrush/Manifest b/media-gfx/pngcrush/Manifest
index bee32073a42f..45e92cecad0b 100644
--- a/media-gfx/pngcrush/Manifest
+++ b/media-gfx/pngcrush/Manifest
@@ -1,2 +1 @@
DIST pngcrush-1.8.13-nolib.tar.xz 66104 BLAKE2B dad0bce2e8f2a135d085343da98ebecfb78a6b05019d43be1b0b1f940ce23ffa980bcb08e8948b6b8cc3efc04bc6ae92a0b9cf8ea8183e27eebfae4c6c48e31e SHA512 c073d573e9b13b72fa39b178271ce65d1a19fef35943ef0a9e6121a5c66d9db212aaad38ab777c5b44e20a107eb677003acbdb4a354bcb2dc40f535a97d9df0e
-DIST pngcrush-1.8.13.tar.xz 404564 BLAKE2B 6e3e9556b40f5616a488cd4d0fbbe788b31d965b748222383741e9dc0c8fe7c12880b2d2a39ef35aa41adbab1fa9f49e7272dadfbe74cc712a7b810a9787d9af SHA512 5fdb7913ec8c90af63d68477f4031c9008dac0d7f4bfd7bd47e971d218e3ef8b0e1a8bf6ba0f5d2cc4c2682c9297efb4f738b11538ad306eee5d01277ce3f628
diff --git a/media-gfx/pngcrush/metadata.xml b/media-gfx/pngcrush/metadata.xml
index 5081ca62df6c..fd6dd7f9aac7 100644
--- a/media-gfx/pngcrush/metadata.xml
+++ b/media-gfx/pngcrush/metadata.xml
@@ -13,7 +13,4 @@
<bugs-to>https://sourceforge.net/p/pmt/bugs/</bugs-to>
<remote-id type="sourceforge">pmt</remote-id>
</upstream>
- <use>
- <flag name="system-libs">Use libpng and libz provided by system</flag>
- </use>
</pkgmetadata>
diff --git a/media-gfx/pngcrush/pngcrush-1.8.13.ebuild b/media-gfx/pngcrush/pngcrush-1.8.13.ebuild
index a84cc5c727f0..ba4efcf233b3 100644
--- a/media-gfx/pngcrush/pngcrush-1.8.13.ebuild
+++ b/media-gfx/pngcrush/pngcrush-1.8.13.ebuild
@@ -2,29 +2,23 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="Portable Network Graphics (PNG) optimizing utility"
HOMEPAGE="https://pmt.sourceforge.io/pngcrush/"
-SRC_URI="system-libs? ( mirror://sourceforge/pmt/${P}-nolib.tar.xz )
- !system-libs? ( mirror://sourceforge/pmt/${P}.tar.xz )"
+SRC_URI="mirror://sourceforge/pmt/${P}-nolib.tar.xz"
LICENSE="pngcrush"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="+system-libs"
-RDEPEND="
- system-libs? (
- media-libs/libpng:0=
- sys-libs/zlib:=
- )"
+RDEPEND="media-libs/libpng:0=
+ sys-libs/zlib:="
DEPEND="${RDEPEND}
app-arch/xz-utils"
-pkg_setup() {
- use system-libs && S+="-nolib"
-}
+S="${WORKDIR}"/${P}-nolib
src_compile() {
emake \