summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-01 07:59:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-01 08:00:22 +0200
commit755d296048de0477d2608299f6e5f9dcb5ec1af4 (patch)
treeb8d8ec4528722dd78b393931e88d72bb33a1499b
parentdev-ruby/i18n: add missing test dep (diff)
downloadgentoo-755d2960.tar.gz
gentoo-755d2960.tar.bz2
gentoo-755d2960.zip
sys-libs/compiler-rt: Try the runtimes build for 15.x
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
index 8af221eaa8ad..8ef4aebf481d 100644
--- a/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
@@ -32,7 +32,7 @@ BDEPEND="
)
"
-LLVM_COMPONENTS=( compiler-rt cmake llvm/cmake )
+LLVM_COMPONENTS=( runtimes compiler-rt cmake llvm/cmake )
LLVM_PATCHSET=9999-1
llvm.org_set_globals
@@ -70,7 +70,6 @@ src_configure() {
# pre-set since we need to pass it to cmake
BUILD_DIR=${WORKDIR}/${P}_build
- local nolib_flags=( -nodefaultlibs -nostartfiles -lc )
if use clang; then
# Only do this conditionally to allow overriding with
# e.g. CC=clang-13 in case of breakage
@@ -79,18 +78,14 @@ src_configure() {
local -x CXX=${CHOST}-clang++
fi
strip-unsupported-flags
- # ensure we can use clang before installing compiler-rt
- local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- elif ! test_compiler; then
- if test_compiler "${nolib_flags[@]}"; then
- local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
- fi
fi
local mycmakeargs=(
- -DCOMPILER_RT_INSTALL_PATH="${EPREFIX}/usr/lib/clang/${SLOT}"
+ -DLLVM_ENABLE_RUNTIMES=compiler-rt
+ # this only adds unnecessary req on llvm-lit directory
+ -DLLVM_INCLUDE_TESTS=OFF
+ -DCOMPILER_RT_INSTALL_PATH="${EPREFIX}/usr/lib/clang/${SLOT}"
-DCOMPILER_RT_INCLUDE_TESTS=$(usex test)
-DCOMPILER_RT_BUILD_LIBFUZZER=OFF
-DCOMPILER_RT_BUILD_MEMPROF=OFF