summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-06-05 17:04:54 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-06-05 17:04:54 +0200
commit7560f7f8272639ac6b09398dadf33ad5d0cce838 (patch)
tree50d68a9716cb95379aac6cd429f6cfb12154f9ea
parentdev-libs/libmodbus: add 3.1.7 (diff)
downloadgentoo-7560f7f8.tar.gz
gentoo-7560f7f8.tar.bz2
gentoo-7560f7f8.zip
net-libs/librouteros: EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-libs/librouteros/files/librouteros-1.1.2-remove-Werror.patch11
-rw-r--r--net-libs/librouteros/librouteros-1.1.2-r1.ebuild (renamed from net-libs/librouteros/librouteros-1.1.2.ebuild)15
2 files changed, 6 insertions, 20 deletions
diff --git a/net-libs/librouteros/files/librouteros-1.1.2-remove-Werror.patch b/net-libs/librouteros/files/librouteros-1.1.2-remove-Werror.patch
deleted file mode 100644
index b3f005a4be3a..000000000000
--- a/net-libs/librouteros/files/librouteros-1.1.2-remove-Werror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -1,7 +1,7 @@
- AUTOMAKE_OPTIONS = foreign no-dependencies
-
- if COMPILER_IS_GCC
--AM_CFLAGS = -Wall -Werror
-+AM_CFLAGS = -Wall
- if BUILD_WITH_DEBUG
- AM_CFLAGS += -Wextra -g -O0
- endif
diff --git a/net-libs/librouteros/librouteros-1.1.2.ebuild b/net-libs/librouteros/librouteros-1.1.2-r1.ebuild
index a6be5fce2804..1dcb908abd88 100644
--- a/net-libs/librouteros/librouteros-1.1.2.ebuild
+++ b/net-libs/librouteros/librouteros-1.1.2-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
DESCRIPTION="Library for accessing MikroTik's RouterOS via its API"
-HOMEPAGE="http://verplant.org/librouteros/"
-SRC_URI="http://verplant.org/librouteros/files/${P}.tar.bz2"
+HOMEPAGE="https://verplant.org/librouteros/"
+SRC_URI="https://verplant.org/librouteros/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -17,10 +17,9 @@ IUSE="debug"
RDEPEND="dev-libs/libgcrypt:0="
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-remove-Werror.patch )
-
src_prepare() {
default
+ sed -e 's/-Werror//g' -i src/Makefile.am || die
eautoreconf
}
@@ -30,7 +29,5 @@ src_configure() {
src_install() {
default
-
- # no static archives
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}