summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:12:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:52 +0200
commit756aa08cd46a839eec218c221db0a0f9c0b6d39c (patch)
tree1fd9bb60593b06b7d332651c01af2c7e80a605a2
parentdev-ros/test_roslib_comm: Bump to 1.13.1. (diff)
downloadgentoo-756aa08c.tar.gz
gentoo-756aa08c.tar.bz2
gentoo-756aa08c.zip
dev-ros/test_rosmaster: Bump to 1.13.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-ros/test_rosmaster/Manifest1
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-1.13.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_rosmaster/Manifest b/dev-ros/test_rosmaster/Manifest
index 4257f76db5ce..b02ae533ed40 100644
--- a/dev-ros/test_rosmaster/Manifest
+++ b/dev-ros/test_rosmaster/Manifest
@@ -1,2 +1,3 @@
DIST ros_comm-1.12.7.tar.gz 974568 SHA256 4c141270c9263ba1ceb0d510f9d17bfe229530a277bfe10762e88d25f46efd38 SHA512 7cfc5bf231e8e388102f192d46bd902a2b92d4620938379b362efd250c48f317f5ba6e0aee7398c841392f56c2b79f933ad5ec60eb69492add90fa2ca86a3a8f WHIRLPOOL 7537aa5b781b3426cbaa82bdb07b117045efc3f748af7413e6b52ee63f3b401e403966afb1ea305674a5613f6a191f0afa098ad16e63267ad2ec8e3117996eb0
DIST ros_comm-1.13.0.tar.gz 974811 SHA256 01eee591e0462e267da5c01537faf609c11497b578d4426818919514a8589ea6 SHA512 8cd0f8cb40d51293946a87da0614921150aa87d168e0d38981f0b7eef3c0f514f14ff613efd192c9c898b3a90fedd0cba21a9f337a197377fd946f427369c60b WHIRLPOOL 6054aca71a7afb0a202b2b8e7baf9b06c51e41f86da0959909bfe130a63a88c684a385b7ef6f9ed8ce2c7c766d6ef78ef83fd8bd97b0cc519717087050122307
+DIST ros_comm-1.13.1.tar.gz 1005522 SHA256 da0797365fb88a41005219079bd034e7e04218b75f28d0275d6e5327be3bc903 SHA512 92248a91d7b7b6defd8607d70e5a09c43c9bc242cfc5574acd5b08c3f9b765144c848c0f72551bb2e19789a345c31f43ed420a9e3e7fbe38bf47adeb7c52a9d7 WHIRLPOOL 746e56a5ebc9e500eb7e333c88259aa20d7685930f30a8bf71982f1cef9c7c14ac28d758adbd13d89b66ca6e1ec01816ce6541fe8817b188bf05e3f477914a4a
diff --git a/dev-ros/test_rosmaster/test_rosmaster-1.13.1.ebuild b/dev-ros/test_rosmaster/test_rosmaster-1.13.1.ebuild
new file mode 100644
index 000000000000..69bbd047e7b9
--- /dev/null
+++ b/dev-ros/test_rosmaster/test_rosmaster-1.13.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosmaster"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
+
+src_install() {
+ ros-catkin_src_install
+ dodir /usr/share/${PN}
+ cp -a test "${ED}//usr/share/${PN}/" || die
+}