summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-04 07:39:12 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-04 07:39:12 +0100
commit7574d3f8dd8b25afb11b4b24ac789f50e6b8a351 (patch)
treee018f8876f575a1e556483752aaae1a4f892d989
parentdev-python/mock: Correct all funcsigs deps (diff)
downloadgentoo-7574d3f8.tar.gz
gentoo-7574d3f8.tar.bz2
gentoo-7574d3f8.zip
dev-python/numba: Depend on virtual/funcsigs instead of dev-python/funcsigs
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/numba/numba-0.18.2.ebuild9
-rw-r--r--dev-python/numba/numba-0.19.2.ebuild9
-rw-r--r--dev-python/numba/numba-0.20.0.ebuild9
3 files changed, 12 insertions, 15 deletions
diff --git a/dev-python/numba/numba-0.18.2.ebuild b/dev-python/numba/numba-0.18.2.ebuild
index 0e35b03b34b3..73c7b3185742 100644
--- a/dev-python/numba/numba-0.18.2.ebuild
+++ b/dev-python/numba/numba-0.18.2.ebuild
@@ -4,9 +4,6 @@
EAPI=5
-# test phase is pointless since it errors in circa 60% of 1984 tests
-RESTRICT="test"
-
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -18,16 +15,18 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE="doc examples test"
RDEPEND="
dev-python/llvmlite[${PYTHON_USEDEP}]
>=dev-python/numpy-1.6[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python{2_7,3_3})
- $(python_gen_cond_dep 'dev-python/funcsigs[${PYTHON_USEDEP}]' python2_7)"
+ virtual/funcsigs[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND} )"
+# test phase is pointless since it errors in circa 60% of 1984 tests
+RESTRICT="test"
+
python_compile() {
if ! python_is_python3; then
local CFLAGS="${CFLAGS} -fno-strict-aliasing"
diff --git a/dev-python/numba/numba-0.19.2.ebuild b/dev-python/numba/numba-0.19.2.ebuild
index b8115eca008e..4200848b93bb 100644
--- a/dev-python/numba/numba-0.19.2.ebuild
+++ b/dev-python/numba/numba-0.19.2.ebuild
@@ -4,9 +4,6 @@
EAPI=5
-# test phase is pointless since it errors in circa 60% of 1984 tests
-RESTRICT="test"
-
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -18,17 +15,19 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE="doc examples test"
RDEPEND="
dev-python/llvmlite[${PYTHON_USEDEP}]
>=dev-python/numpy-1.6[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python{2_7,3_3})
- $(python_gen_cond_dep 'dev-python/funcsigs[${PYTHON_USEDEP}]' python2_7)"
+ virtual/funcsigs[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND} )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# test phase is pointless since it errors in circa 60% of 1984 tests
+RESTRICT="test"
+
# Delete intersphinx & entry to set sphinxjp.themecore, which is absent from portage, from conf.py
PATCHES=( "${FILESDIR}"/${P}-docbuild.patch )
diff --git a/dev-python/numba/numba-0.20.0.ebuild b/dev-python/numba/numba-0.20.0.ebuild
index 1af7b26533ed..2631c41c658e 100644
--- a/dev-python/numba/numba-0.20.0.ebuild
+++ b/dev-python/numba/numba-0.20.0.ebuild
@@ -4,9 +4,6 @@
EAPI=5
-# test phase is pointless since it errors in circa 60% of 1984 tests
-RESTRICT="test"
-
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -18,17 +15,19 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE="doc examples test"
RDEPEND="
dev-python/llvmlite[${PYTHON_USEDEP}]
>=dev-python/numpy-1.6[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python{2_7,3_3})
- $(python_gen_cond_dep 'dev-python/funcsigs[${PYTHON_USEDEP}]' python2_7)"
+ virtual/funcsigs[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND} )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# test phase is pointless since it errors in circa 60% of 1984 tests
+RESTRICT="test"
+
# Delete intersphinx & entry to set sphinxjp.themecore, which is absent from portage, from conf.py
PATCHES=( "${FILESDIR}"/${PN}-0.19.2-docbuild.patch )