summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2018-08-05 09:45:12 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2018-08-05 09:46:29 +0200
commit75ad47ec2124ff3e8d4ddd010e89b65958b3a4d9 (patch)
treead52500e0705fd0245a354b78cf5ef3c4e46256d
parentdev-ruby/combustion: add ruby25 (diff)
downloadgentoo-75ad47ec.tar.gz
gentoo-75ad47ec.tar.bz2
gentoo-75ad47ec.zip
app-backup/bacula: Add patch to work with >=dev-libs/libressl-2.7
Apply different patches according to dev-libs/libressl version (<2.7 and >=2.7) installed. Reported-by: Toralf Förster <toralf@gentoo.org> Closes: https://bugs.gentoo.org/655520 Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--app-backup/bacula/bacula-9.0.6-r3.ebuild8
-rw-r--r--app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl26.patch (renamed from app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl.patch)0
-rw-r--r--app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl27.patch11
3 files changed, 18 insertions, 1 deletions
diff --git a/app-backup/bacula/bacula-9.0.6-r3.ebuild b/app-backup/bacula/bacula-9.0.6-r3.ebuild
index f30acaa0b53f..0c4d61e2a766 100644
--- a/app-backup/bacula/bacula-9.0.6-r3.ebuild
+++ b/app-backup/bacula/bacula-9.0.6-r3.ebuild
@@ -169,7 +169,13 @@ src_prepare() {
chmod 755 src/qt-console/.libs/bat || die
# fix wrong handling of libressl version
- eapply -p0 "${FILESDIR}"/9.0.6/${PN}-9.0.6-libressl.patch
+ # needs separate handling for <libressl-2.7 and >=libressl2.7
+ # (see bug #655520)
+ if has_version "<dev-libs/libressl-2.7"; then
+ eapply -p0 "${FILESDIR}"/9.0.6/${PN}-9.0.6-libressl26.patch
+ else
+ eapply -p0 "${FILESDIR}"/9.0.6/${PN}-9.0.6-libressl27.patch
+ fi
# fix bundled libtool (bug 466696)
# But first move directory with M4 macros out of the way.
diff --git a/app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl.patch b/app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl26.patch
index 3df4285c2e2e..3df4285c2e2e 100644
--- a/app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl.patch
+++ b/app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl26.patch
diff --git a/app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl27.patch b/app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl27.patch
new file mode 100644
index 000000000000..b87f4b13f9f8
--- /dev/null
+++ b/app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl27.patch
@@ -0,0 +1,11 @@
+--- src/lib/crypto.c.orig 2018-02-02 15:34:39.420489000 -0600
++++ src/lib/crypto.c 2018-02-02 15:35:44.000524000 -0600
+@@ -195,7 +195,7 @@
+ IMPLEMENT_ASN1_FUNCTIONS(SignatureData)
+ IMPLEMENT_ASN1_FUNCTIONS(CryptoData)
+
+-#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
++#if ( (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER) )
+ DEFINE_STACK_OF(SignerInfo);
+ DEFINE_STACK_OF(RecipientInfo);
+ #else