summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-12-10 21:21:27 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-12-10 21:40:17 +0900
commit75dcb1f96d13c2207dac4fd7e976fa2c09e1fcee (patch)
tree5ab92e2cfe3d7be04cda7e79ad99a15d31c4608b
parentapp-text/namazu: update patches (diff)
downloadgentoo-75dcb1f96d13c2207dac4fd7e976fa2c09e1fcee.tar.gz
gentoo-75dcb1f96d13c2207dac4fd7e976fa2c09e1fcee.tar.bz2
gentoo-75dcb1f96d13c2207dac4fd7e976fa2c09e1fcee.zip
app-text/namazu: update to EAPI 6
Package-Manager: Portage-2.3.13, Repoman-2.3.4
-rw-r--r--app-text/namazu/files/50namazu-gentoo.el3
-rw-r--r--app-text/namazu/namazu-2.0.21.ebuild34
-rw-r--r--app-text/namazu/namazu-2.0.22_p1.ebuild47
3 files changed, 48 insertions, 36 deletions
diff --git a/app-text/namazu/files/50namazu-gentoo.el b/app-text/namazu/files/50namazu-gentoo.el
index 56bbce50af82..e2f6e501241c 100644
--- a/app-text/namazu/files/50namazu-gentoo.el
+++ b/app-text/namazu/files/50namazu-gentoo.el
@@ -1,5 +1,2 @@
-
-;; namazu site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'namazu "namazu" nil t)
diff --git a/app-text/namazu/namazu-2.0.21.ebuild b/app-text/namazu/namazu-2.0.21.ebuild
index ac2d382288d5..4e9e19466449 100644
--- a/app-text/namazu/namazu-2.0.21.ebuild
+++ b/app-text/namazu/namazu-2.0.21.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-inherit autotools eutils elisp-common
+inherit autotools elisp-common ltprune
DESCRIPTION="Namazu is a full-text search engine"
HOMEPAGE="http://www.namazu.org/"
@@ -12,9 +12,9 @@ SRC_URI="http://www.namazu.org/stable/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="emacs nls tk l10n_ja"
+IUSE="emacs l10n_ja nls static-libs tk"
-RDEPEND=">=dev-perl/File-MMagic-1.20
+RDEPEND="dev-perl/File-MMagic
emacs? ( virtual/emacs )
l10n_ja? (
app-i18n/nkf
@@ -33,9 +33,13 @@ RDEPEND=">=dev-perl/File-MMagic-1.20
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${P}-memmove.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-gentoo.patch
- epatch "${FILESDIR}"/${P}-memmove.patch
+ default
mv configure.{in,ac}
mv tk${PN}/configure.{in,ac}
@@ -45,14 +49,13 @@ src_prepare() {
src_configure() {
local myconf=(
$(use_enable nls)
- $(use_enable tk tknamazu)
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable static-libs static)
+ $(use_enable tk tk${PN})
)
use tk && myconf+=(
- --with-namazu=/usr/bin/namazu
- --with-mknmz=/usr/bin/mknmz
- --with-indexdir=/var/lib/namazu/index
+ --with-${PN}="${EPREFIX}"/usr/bin/${PN}
+ --with-mknmz="${EPREFIX}"/usr/bin/mknmz
+ --with-indexdir="${EPREFIX}"/var/lib/${PN}/index
)
econf "${myconf[@]}"
@@ -63,7 +66,8 @@ src_compile() {
if use emacs; then
cd lisp
- elisp-compile gnus-nmz-1.el namazu.el
+ rm -f browse*
+ elisp-compile *.el
fi
}
@@ -71,12 +75,14 @@ src_install () {
emake DESTDIR="${D}" install
if use emacs; then
- elisp-install ${PN} lisp/gnus-nmz-1.el* lisp/namazu.el*
+ elisp-install ${PN} lisp/*.el*
elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
docinto lisp
dodoc lisp/ChangeLog*
fi
+
+ prune_libtool_files
}
pkg_postinst() {
diff --git a/app-text/namazu/namazu-2.0.22_p1.ebuild b/app-text/namazu/namazu-2.0.22_p1.ebuild
index ed4b7d27b3f0..8889da50fc46 100644
--- a/app-text/namazu/namazu-2.0.22_p1.ebuild
+++ b/app-text/namazu/namazu-2.0.22_p1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-AUTOTOOLS_AUTORECONF="1"
-inherit autotools-utils eutils elisp-common
+inherit autotools elisp-common ltprune
DESCRIPTION="Namazu is a full-text search engine"
HOMEPAGE="http://www.namazu.org/"
@@ -13,9 +12,9 @@ SRC_URI="http://www.namazu.org/test/${P/_p/pre}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="emacs nls tk l10n_ja"
+IUSE="emacs l10n_ja nls static-libs tk"
-RDEPEND=">=dev-perl/File-MMagic-1.20
+RDEPEND="dev-perl/File-MMagic
emacs? ( virtual/emacs )
l10n_ja? (
app-i18n/nkf
@@ -37,41 +36,51 @@ S="${WORKDIR}"/${P/_p/pre}
PATCHES=( "${FILESDIR}"/${PN}-gentoo.patch )
+src_prepare() {
+ default
+
+ mv configure.{in,ac}
+ mv tk${PN}/configure.{in,ac}
+ eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
+ local myconf=(
$(use_enable nls)
- $(use_enable tk tknamazu)
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable static-libs static)
+ $(use_enable tk tk${PN})
)
-
- use tk && myeconfargs+=(
- --with-namazu=/usr/bin/namazu
- --with-mknmz=/usr/bin/mknmz
- --with-indexdir=/var/lib/namazu/index
+ use tk && myconf+=(
+ --with-${PN}="${EPREFIX}"/usr/bin/${PN}
+ --with-mknmz="${EPREFIX}"/usr/bin/mknmz
+ --with-indexdir="${EPREFIX}"/var/lib/${PN}/index
)
- autotools-utils_src_configure
+
+ econf "${myconf[@]}"
}
src_compile() {
- autotools-utils_src_compile
+ emake
if use emacs; then
cd lisp
- elisp-compile gnus-nmz-1.el namazu.el
+ rm -f browse*
+ elisp-compile *.el
fi
}
src_install () {
- autotools-utils_src_install
+ emake DESTDIR="${D}" install
if use emacs; then
- elisp-install ${PN} lisp/gnus-nmz-1.el* lisp/namazu.el*
+ elisp-install ${PN} lisp/*.el*
elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
docinto lisp
dodoc lisp/ChangeLog*
fi
+
+ prune_libtool_files
}
pkg_postinst() {