summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-30 11:20:07 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-30 11:20:07 +0200
commit760c81eb61289e88af4858c01b8561b1f26385c1 (patch)
tree46a30f6c90399c5e93f270dc1d90a0d02d5e5ba0
parentmedia-sound/tagtool: inherit xdg (diff)
downloadgentoo-760c81eb.tar.gz
gentoo-760c81eb.tar.bz2
gentoo-760c81eb.zip
net-analyzer/fprobe: drop 1.1-r3
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-analyzer/fprobe/files/conf.d-fprobe71
-rw-r--r--net-analyzer/fprobe/files/init.d-fprobe41
-rw-r--r--net-analyzer/fprobe/fprobe-1.1-r3.ebuild43
3 files changed, 0 insertions, 155 deletions
diff --git a/net-analyzer/fprobe/files/conf.d-fprobe b/net-analyzer/fprobe/files/conf.d-fprobe
deleted file mode 100644
index a93c5c10b207..000000000000
--- a/net-analyzer/fprobe/files/conf.d-fprobe
+++ /dev/null
@@ -1,71 +0,0 @@
-# Config file for /etc/init.d/fprobe
-
-# Do we want the interface in promiscous mode [yes/no]
-#PROMISC=no
-
-# Interface
-IFACE=eth0
-
-# If configured, only capture packets matching this tcpdump expression
-#FILTER=""
-
-# Flow state timers
-#TIMER_EXPIRED=5
-#TIMER_FRAGMENTED=30
-#TIMER_IDLE=60
-#TIMER_ACTIVE=300
-
-# This is the default and should be left unless you know what you are doing
-#FLOW_VER=5
-
-# local ip. if configured fprobe will use this as the source IP for sending ALL flow data
-# If you want to specify a specific source address per collecter, customize it below
-#LOCALIP=
-
-# SNMP iface id
-SNMP_IFACE="${IFACE#eth}"
-
-# Maximum number of concurrent flows to track
-# using a specified amount of memory
-#MEMBULK=10000
-#MEMLIMIT=
-
-# Pending queue
-#PENDING=100
-
-# Kernel capture buffer size (kB)
-#KERNBUF=1024
-
-# Realtime priority [0=disabled, 1..99]
-#RTPRIO=0
-
-# Delay N nanoseconds after each B bytes
-#DELAY="0:0"
-
-# How much of the start of each packet to grab
-#SNAPLEN=256
-
-# chroot() to this location after startup
-CHROOT="/var/empty"
-
-# User to run as. must have perms to the pidfile directory /var/run/fprobe/
-USER=nobody
-
-# logging level for syslog (0=EMERG, ..., 6=INFO, 7=DEBUG)
-#LOGLEVEL=6
-
-# If you want to run multiple instances of fprobe,
-# You MUST set this variable to a unique INTEGER for each one!
-PIDFILE_ID=''
-
-# remote ip. this is where we send flows
-REMOTEIP=127.0.0.1
-# port to listen on
-PORT=2055
-# Collector type, see the manpage for valid types
-TYPE=''
-
-# If you want multiple collectors, just specify each one here
-COLLECTORS="${REMOTEIP}:${PORT}/${LOCALIP}/${TYPE}"
-
-# vim:ft=gentoo-conf-d:
diff --git a/net-analyzer/fprobe/files/init.d-fprobe b/net-analyzer/fprobe/files/init.d-fprobe
deleted file mode 100644
index c470af432c9c..000000000000
--- a/net-analyzer/fprobe/files/init.d-fprobe
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
-}
-
-BIN=/usr/sbin/fprobe
-PIDFILE_EXTRA=""
-[ -n "$PIDFILE_ID" ] && PIDFILE_EXTRA="[$PIDFILE_ID]"
-PIDFILE="/var/run/fprobe$PIDFILE_EXTRA.pid"
-
-start() {
- ebegin "Starting fprobe"
- local OPTS=""
- [ "${PROMISC}" = "yes" ] || OPTS="${OPTS} -p"
- [ -n "${FILTER}" ] && OPTS="${OPTS} -f '${FILTER}'"
- for optname in i:IFACE s:TIMER_EXPIRED g:TIME_FRAGMENTED d:TIMER_IDLE \
- e:TIMER_ACTIVE n:FLOW_VER a:LOCALIP x:SNMP_IFACE b:MEMBULK \
- m:MEMLIMIT q:PENDING B:KERNBUF r:RTPRIO t:DELAY S:SNAPLEN \
- c:CHROOT u:USER v:LOGLEVEL ; do
- opt="${optname%:*}" optvar="${optname#*:}"
- eval optvalue='$'$optvar
- [ -n "$optvalue" ] && OPTS="${OPTS} -${opt} ${optvalue}"
- done
- OPTS="${OPTS} -l 1:${PIDFILE_ID} ${COLLECTORS}"
- start-stop-daemon --start --exec $BIN \
- --pidfile ${PIDFILE} \
- -- ${OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping fprobe"
- start-stop-daemon --stop --quiet --exec $BIN \
- --pidfile ${PIDFILE}
- eend $?
-}
-
-# vim:ft=gentoo-init-d:
diff --git a/net-analyzer/fprobe/fprobe-1.1-r3.ebuild b/net-analyzer/fprobe/fprobe-1.1-r3.ebuild
deleted file mode 100644
index d86d043a9c3f..000000000000
--- a/net-analyzer/fprobe/fprobe-1.1-r3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="libpcap-based tool to collect network traffic data and emit it as NetFlow flows"
-HOMEPAGE="http://fprobe.sourceforge.net"
-LICENSE="GPL-2"
-
-SRC_URI="mirror://sourceforge/fprobe/${P}.tar.bz2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-
-IUSE="debug messages"
-
-DEPEND="
- net-libs/libpcap
-"
-RDEPEND="
- ${DEPEND}
-"
-PATCHES=(
- "${FILESDIR}"/fprobe-1.1-pidfile-sanity.patch
- "${FILESDIR}"/fprobe-1.1-setgroups.patch
-)
-
-src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable messages)
-}
-
-DOCS=( AUTHORS NEWS README TODO )
-
-src_install() {
- default
-
- docinto contrib
- dodoc contrib/tg.sh
-
- newinitd "${FILESDIR}"/init.d-fprobe fprobe
- newconfd "${FILESDIR}"/conf.d-fprobe fprobe
-}