summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-07-18 13:10:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-07-18 13:10:58 -0500
commit761979dd4d6ab72b821e2adb45ab8b77fea595fd (patch)
tree38423fc4ccdeb7cf995b5803574f64be51ab28ce
parentapp-admin/ansible: add 8.2.0 (diff)
downloadgentoo-761979dd4d6ab72b821e2adb45ab8b77fea595fd.tar.gz
gentoo-761979dd4d6ab72b821e2adb45ab8b77fea595fd.tar.bz2
gentoo-761979dd4d6ab72b821e2adb45ab8b77fea595fd.zip
app-admin/ansible: add 7.7.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-7.7.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 1e916c5a1022..ec6daccab2ed 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,4 +1,5 @@
DIST ansible-6.7.0.tar.gz 36371372 BLAKE2B 75cb14f158c36ded8313a1c5b798838afdf3a38ffc8e29a87c8e1e3e74c9aeca827432397ad83ed23a1d3aeaaef91822cc3c23aa226a307d93f84f54b25d71bb SHA512 676baf03626d5bf36aea7117d39ef71ba7878ab6bccdec1ee199bd699d559a5f3f6a0d9032ef120204093677b7fbbe1b575529d3aa692acd1a4447f9c2715f3a
DIST ansible-7.6.0.tar.gz 38452799 BLAKE2B 88b652b1b0bcbedb982606c7d7734fd11567cd492f4e0d617d7412e1bac8978fcef1f4201bb0338098204640e2b004d8921427c1d642bfbb15a7f95b134cb85e SHA512 4f8960356e0ff855d54b435ed691d1d4f7d38c1231269e35b3dbbee536a9d8d1aef2806d7ce38e863fe216e9fddb2f86ce55ba997a3bd1d8bb7f43c5c519ff72
+DIST ansible-7.7.0.tar.gz 40709642 BLAKE2B ee2f8d124f79ca3a3f131bfbc4f93e10d104a38262b7d60edd2a88284275fecdd3acf0e566a5cc81a1fb6a179a0b7c51215f2945d669be4c6af7aa2a4f31ade0 SHA512 7da6845c9a68f2b8c10cf3e4cc6ea347861d5b59daa6ac895731ac79b733c6724d234345054fe9e3bf4ea460345b9026492fda42dce22bfbc027c9b4de093fd9
DIST ansible-8.0.0.tar.gz 36842561 BLAKE2B 999760b334918d807f0d5de888864c86b686fef24d4d94cc959902d4d4ed3ea321358b574fb9a2358e182c71d6237c686eead4cf37cc65755685714589e7df2b SHA512 637304599ec2074b473902d767a9e42d4df17c8485e5d64b6a1ea8a3b8ad347f021aeb88ca5cdbd2eefc30f2d8d2870e8934fa2c4d9c192c03a1482b31cc1fc5
DIST ansible-8.2.0.tar.gz 39618057 BLAKE2B 26e737989d7cc118aaab18c51ef3bd7c33173ec95e603b328a82b247be47fa9cb6b6d384cb56da7ead3675f3766ae655a3b7955f8c262519f54147d832a0ac94 SHA512 0ed3f43885b026c18939a29ef67f836374cdeaf96c3445fb59ec60164493820ac2e97c041daddd49ba083d0bef8cac4b7a75d5391290fce52bebae02276b0be6
diff --git a/app-admin/ansible/ansible-7.7.0.ebuild b/app-admin/ansible/ansible-7.7.0.ebuild
new file mode 100644
index 000000000000..b74fccd0afab
--- /dev/null
+++ b/app-admin/ansible/ansible-7.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.14.0
+ <app-admin/ansible-core-2.15"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}