summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-17 16:01:56 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-17 16:12:35 +0200
commit7621aec8d20fcb946c85ea34f5ffdd617367d2cd (patch)
tree224f5b15ab9dc779720b070f9a6bdb61737a39f3
parentnet-vpn/riseup-vpn: add 0.24.5 (diff)
downloadgentoo-7621aec8d20fcb946c85ea34f5ffdd617367d2cd.tar.gz
gentoo-7621aec8d20fcb946c85ea34f5ffdd617367d2cd.tar.bz2
gentoo-7621aec8d20fcb946c85ea34f5ffdd617367d2cd.zip
dev-python/superqt: add 0.6.6
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/superqt/Manifest1
-rw-r--r--dev-python/superqt/superqt-0.6.6.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/superqt/Manifest b/dev-python/superqt/Manifest
index e3c34fc11b5b..1aef85c92304 100644
--- a/dev-python/superqt/Manifest
+++ b/dev-python/superqt/Manifest
@@ -1 +1,2 @@
DIST superqt-0.6.4.tar.gz 95502 BLAKE2B 0354fbea1925bac84a72fc1d8e0402ba80fdd38cdec32a0e91c4b360dc8d906d631e5e36ffea8d20baae9d1e620417a08f19c2d4d37778f2e50ca3673e12bca3 SHA512 934df6d7c0dd80e045a03b88fb6b254fd7f7e3a09c882bcd46c3635ed7ba434c5704b110dd590a491fc9cead767c2f885245fdae09ef26e1a1e556d66cb2d7a3
+DIST superqt-0.6.6.tar.gz 96181 BLAKE2B 6f42e5279067d409cb9d54bf0d673d04695ae529be61dcf04e6c280fe6555400725742f075f5fcf197a79aa834d73874955a09f3062ee07ebd6598632bbb1635 SHA512 1ed0ca445b6f2ac7ecc7c5c6339249a88eff7f10d67f23bc4052666beba68399b4062f9c2bc9677fd643110513332b7ee65be50d8e77868e3c8d4ff278029b1c
diff --git a/dev-python/superqt/superqt-0.6.6.ebuild b/dev-python/superqt/superqt-0.6.6.ebuild
new file mode 100644
index 000000000000..d28d26f40bb0
--- /dev/null
+++ b/dev-python/superqt/superqt-0.6.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Missing widgets and components for PyQt/PySide"
+HOMEPAGE="
+ https://github.com/pyapp-kit/superqt
+ https://pypi.org/project/superqt/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.7.4.3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # pint and pyconify not packaged
+ tests/test_quantity.py
+)
+
+EPYTEST_DESELECT=(
+ # fails in the sandbox, but works outside of it
+ tests/test_eliding_label.py::test_wrapped_eliding_label
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx distutils-r1_python_test
+}