summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-01 11:14:15 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-01 11:14:15 +0100
commit762ae8c32889f933907bfbacbafd201cb33c9304 (patch)
tree81744184a19657774b8bac3081765e07b7af11fd
parentacct-user/mpd: fix description grammar (diff)
downloadgentoo-762ae8c3288.tar.gz
gentoo-762ae8c3288.tar.bz2
gentoo-762ae8c3288.zip
dev-libs/double-conversion: Remove USE="static-libs"
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/double-conversion/double-conversion-3.1.5.ebuild44
1 files changed, 2 insertions, 42 deletions
diff --git a/dev-libs/double-conversion/double-conversion-3.1.5.ebuild b/dev-libs/double-conversion/double-conversion-3.1.5.ebuild
index a5d39a82e107..f1eee1853367 100644
--- a/dev-libs/double-conversion/double-conversion-3.1.5.ebuild
+++ b/dev-libs/double-conversion/double-conversion-3.1.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake multibuild
+inherit cmake
DESCRIPTION="Binary-decimal and decimal-binary conversion routines for IEEE doubles"
HOMEPAGE="https://github.com/google/double-conversion"
@@ -12,43 +12,3 @@ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0/3"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
-
-RESTRICT="!test? ( test )"
-
-pkg_setup() {
- MULTIBUILD_VARIANTS=( shared $(usev static-libs) )
-}
-
-src_configure() {
- myconfigure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test)
- )
- if [[ ${MULTIBUILD_VARIANT} = static-libs ]]; then
- mycmakeargs+=( -DBUILD_SHARED_LIBS=OFF )
- fi
-
- cmake_src_configure
- }
-
- multibuild_foreach_variant myconfigure
-}
-
-src_compile() {
- multibuild_foreach_variant cmake_src_compile
-}
-
-src_test() {
- [[ ${MULTIBUILD_VARIANT} = shared ]] && cmake_src_test
-}
-
-src_install() {
- myinstall() {
- [[ ${MULTIBUILD_VARIANT} = shared ]] && cmake_src_install
- [[ ${MULTIBUILD_VARIANT} = static-libs ]] && \
- dolib.a ${BUILD_DIR}/libdouble-conversion.a
- }
-
- multibuild_foreach_variant myinstall
-}