summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-09 05:08:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-09 05:22:36 +0200
commit762ed5176252ca0a836be9e82200853df7ea10c4 (patch)
treebdb8f38c037ccec04c72db36af2a8e316a2a2d23
parentdev-python/fakeredis: Bump to 2.18.1 (diff)
downloadgentoo-762ed5176252ca0a836be9e82200853df7ea10c4.tar.gz
gentoo-762ed5176252ca0a836be9e82200853df7ea10c4.tar.bz2
gentoo-762ed5176252ca0a836be9e82200853df7ea10c4.zip
dev-python/pip-run: Bump to 12.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/pip-run-12.2.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 51c4ab889d69..2053e43e8279 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1,2 +1,3 @@
DIST pip-run-10.2.0.tar.gz 33523 BLAKE2B 7d19c089da98dbba2faec969f490fcd5ea48881f4ccbbfaa283465ef083521aee7d82b9de8b03a89ec8b08005db1232cd9577030cb98c111b4a0e0f7294cca84 SHA512 b26a00c6ebd8e9e505e6b218fea7070b23b5926de44e1d5a762abb2a4ebd62b1bdda7e19c4092012daf068b518a2e127ab08099f6d1a7ddc643b3ba5bf999ed0
DIST pip-run-12.1.0.tar.gz 34387 BLAKE2B 306dce020589a0cdcaddc70baf75a41621c72a450af58a2f54c5128f8210b02f4ee2b4df5b8bca1e0617ef53e79ab89969765b053801dc4f9d60bddf7c40e76e SHA512 fa1c36b6b5befada7b54841723f9cd7ef6289bb723b46cbe000ccfc7a6e894181fbf58f472330830e5812aab8feb40dab8708cd82532696e510bd56ab0b70a20
+DIST pip-run-12.2.0.tar.gz 36557 BLAKE2B a711b984895937546b066accf6e51213ddce2c5a7fff77fd018d3588054968fd3b1560f343f98474944302fe12629272ba1fe374c97b5ab8b6ca4694d4b05081 SHA512 a49a94f163a1344d289d53402b41ba31dceab360040e936a3129a7ac7f8c85eb71d4da5a37e517c8a626e6beac2a3265e617b8e63050f0e952bc94969b3dc6ee
diff --git a/dev-python/pip-run/pip-run-12.2.0.ebuild b/dev-python/pip-run/pip-run-12.2.0.ebuild
new file mode 100644
index 000000000000..5cc2fbb52d69
--- /dev/null
+++ b/dev-python/pip-run/pip-run-12.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-env[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.7[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flit-core[${PYTHON_USEDEP}]
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+
+ if ! has_version "dev-python/nbformat[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_scripts.py
+ )
+ fi
+
+ epytest -m "not network"
+}