summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-28 05:21:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-28 06:03:40 +0200
commit7643aea7c83dfc12adcf2669bdd525be83d64270 (patch)
tree797f2eb467ae2b8d930ce8a4f79454c4706865b4
parentapp-admin/awscli: Bump to 1.25.18 (diff)
downloadgentoo-7643aea7.tar.gz
gentoo-7643aea7.tar.bz2
gentoo-7643aea7.zip
dev-python/suds-community: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/suds-community/Manifest1
-rw-r--r--dev-python/suds-community/suds-community-1.1.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/suds-community/Manifest b/dev-python/suds-community/Manifest
index 23a7eb0658c5..e21933e8f839 100644
--- a/dev-python/suds-community/Manifest
+++ b/dev-python/suds-community/Manifest
@@ -1 +1,2 @@
DIST suds-community-1.1.1.tar.gz 284934 BLAKE2B 9df1a5f6b4dd2ca060c639147a090cef6a194f275706e03a3fdafa46c4d18b890f7c94249db8db6202e95abea71948e0c42fe42f14f659ca14bb0aca11b4b5f5 SHA512 9b343d704b2db123ff44685fb03da8f6912cefb32d38e9b79f9f84aeebff32ba26936a0f70a6121628c6f2c5388e94d380f08ed546f55fbf84fdc8e4fdbd3d0a
+DIST suds-community-1.1.2.tar.gz 285409 BLAKE2B 6cf047bb6fa6aed147fa519fee4300f52195c94a409aaa769feffaaf4d43552a566efb0162e440092c3dcb8ec21cf441325db449e5417b81a5f859133a078b83 SHA512 9f26ebbf36fcbd915281f3c3afd4ea776ca409ede4ba9e487b746ef4e527171ee2fdb44075100d52b5bba0658fafec817eea2cbf64b8d2851bdc974aee430d57
diff --git a/dev-python/suds-community/suds-community-1.1.2.ebuild b/dev-python/suds-community/suds-community-1.1.2.ebuild
new file mode 100644
index 000000000000..a41f925a470f
--- /dev/null
+++ b/dev-python/suds-community/suds-community-1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="xml(+)"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight SOAP client"
+HOMEPAGE="
+ https://github.com/suds-community/suds/
+ https://pypi.org/project/suds-community/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README.md notes/. )
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest