summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-09 18:14:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-09 18:14:12 +0200
commit764a2ea361de74f0618ab9547103b055e7c10013 (patch)
tree2e560b094e602acf42338d0a7b18649d01e204f5
parentapp-crypt/certbot-dns-nsone: PEP517, py3.11 (diff)
downloadgentoo-764a2ea361de74f0618ab9547103b055e7c10013.tar.gz
gentoo-764a2ea361de74f0618ab9547103b055e7c10013.tar.bz2
gentoo-764a2ea361de74f0618ab9547103b055e7c10013.zip
app-arch/vimball: EAPI 8, PEP517, py3.11
Closes: https://bugs.gentoo.org/896498 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-arch/vimball/vimball-0.5.1-r1.ebuild28
-rw-r--r--app-arch/vimball/vimball-9999.ebuild14
2 files changed, 37 insertions, 5 deletions
diff --git a/app-arch/vimball/vimball-0.5.1-r1.ebuild b/app-arch/vimball/vimball-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..368e668cb296
--- /dev/null
+++ b/app-arch/vimball/vimball-0.5.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/radhermit/vimball.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ inherit pypi
+fi
+
+DESCRIPTION="A command-line vimball archive extractor"
+HOMEPAGE="
+ https://github.com/radhermit/vimball/
+ https://pypi.org/project/vimball/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_tests pytest
diff --git a/app-arch/vimball/vimball-9999.ebuild b/app-arch/vimball/vimball-9999.ebuild
index ce0b02ce114e..368e668cb296 100644
--- a/app-arch/vimball/vimball-9999.ebuild
+++ b/app-arch/vimball/vimball-9999.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -15,8 +16,11 @@ else
inherit pypi
fi
-DESCRIPTION="a command-line vimball archive extractor"
-HOMEPAGE="https://github.com/radhermit/vimball"
+DESCRIPTION="A command-line vimball archive extractor"
+HOMEPAGE="
+ https://github.com/radhermit/vimball/
+ https://pypi.org/project/vimball/
+"
LICENSE="MIT"
SLOT="0"