summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-01-10 11:08:50 -0300
committerPacho Ramos <pacho@gentoo.org>2024-01-28 12:49:29 +0100
commit764e569807eb71c467c50c65e9b7e0bcb8c7e341 (patch)
tree634db578d472cc8b11bde94be4d79c60cec23f69
parentgnome-extra/zenity: drop 3.99.2, 3.99.90, 3.99.91 (diff)
downloadgentoo-764e569807eb71c467c50c65e9b7e0bcb8c7e341.tar.gz
gentoo-764e569807eb71c467c50c65e9b7e0bcb8c7e341.tar.bz2
gentoo-764e569807eb71c467c50c65e9b7e0bcb8c7e341.zip
dev-cpp/mm-common: Version bump to 1.0.6
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34735 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--dev-cpp/mm-common/Manifest1
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.6.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/Manifest b/dev-cpp/mm-common/Manifest
index 7c99b5fd1186..a96d23566d81 100644
--- a/dev-cpp/mm-common/Manifest
+++ b/dev-cpp/mm-common/Manifest
@@ -1 +1,2 @@
DIST mm-common-1.0.5.tar.xz 290608 BLAKE2B fcd698e8122fbcbcefcc6cce9460216cb3c3eabb17b309a28b964c9cd99b1329f936070f54b888cf0712e4590b8fe99394a110997ff023ff07dd7a30e55d771b SHA512 bf681b4d63d5bf531a9315b0c8841e3815af276828d1828a3eb04dcb805cbbfbaac182f79f5e48688a7eef8666975b9079144e320093e4ee3addff48813e61ad
+DIST mm-common-1.0.6.tar.xz 287832 BLAKE2B b633f37a470b558c16ce4a260384913ddc64df2ac94e25e2b7b05300c5c7b51826477bff655154572bd7eafe583b4cb056e7c9dee3d3e699dbf200490da0591f SHA512 2141ce9dabdae153e5708b09d30e7917182888e521ff0c2a4f85c7ec2dd86b2c8753e0513bf9c9f9a00d4e579173ffa859a3efd006e706fdfa2f33b0e77af48b
diff --git a/dev-cpp/mm-common/mm-common-1.0.6.ebuild b/dev-cpp/mm-common/mm-common-1.0.6.ebuild
new file mode 100644
index 000000000000..76a84d27d557
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit gnome.org python-any-r1 meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/ https://gitlab.gnome.org/GNOME/mm-common"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}