summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-12 14:36:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-12 16:01:15 +0200
commit764f495d5fd70325f9e907b04f84af29151cbcc1 (patch)
treea9f0f3440dab559655b822e882f6a982cce0d255
parentnet-analyzer/ipsumdump: Add netmon. (diff)
downloadgentoo-764f495d5fd70325f9e907b04f84af29151cbcc1.tar.gz
gentoo-764f495d5fd70325f9e907b04f84af29151cbcc1.tar.bz2
gentoo-764f495d5fd70325f9e907b04f84af29151cbcc1.zip
kde5-functions.eclass: Raise QT_MINIMAL to 5.9.4
But avoid unnecessary non-dynlibs rebuilds in Plasma and Frameworks.
-rw-r--r--eclass/kde5-functions.eclass15
1 files changed, 7 insertions, 8 deletions
diff --git a/eclass/kde5-functions.eclass b/eclass/kde5-functions.eclass
index f9b00431bcc..aab79b0ba9c 100644
--- a/eclass/kde5-functions.eclass
+++ b/eclass/kde5-functions.eclass
@@ -34,30 +34,29 @@ export KDE_BUILD_TYPE
case ${CATEGORY} in
kde-frameworks)
- [[ ${PV} = 5.45* ]] && : ${QT_MINIMAL:=5.9.4}
+ [[ ${PV} = 5.43* ]] && : ${QT_MINIMAL:=5.7.1}
[[ ${KDE_BUILD_TYPE} = live ]] && : ${FRAMEWORKS_MINIMAL:=9999}
;;
kde-plasma)
- [[ ${PV} = 5.12* ]] && : ${QT_MINIMAL:=5.9.1}
- if [[ ${KDE_BUILD_TYPE} = live ]]; then
- : ${QT_MINIMAL:=5.9.1}
+ [[ ${PV} = 5.11.5* ]] && : ${QT_MINIMAL:=5.7.1}
+ [[ ${PV} = 5.12.5* ]] && : ${QT_MINIMAL:=5.9.1}
+ if [[ ${KDE_BUILD_TYPE} = live && ${PV} != 5.12* ]]; then
: ${FRAMEWORKS_MINIMAL:=9999}
+ : ${QT_MINIMAL:=5.10.1}
fi
;;
kde-apps)
+ [[ ${PV} = 17.12.3* ]] && : ${QT_MINIMAL:=5.9.1}
if [[ ${KDE_BUILD_TYPE} = live || ${PV} = 18.04* ]]; then
: ${FRAMEWORKS_MINIMAL:=5.44.0}
fi
- if [[ ${KDE_BUILD_TYPE} = live || ${PV} = 17.12* ]]; then
- : ${QT_MINIMAL:=5.9.1}
- fi
;;
esac
# @ECLASS-VARIABLE: QT_MINIMAL
# @DESCRIPTION:
# Minimum version of Qt to require. This affects add_qt_dep.
-: ${QT_MINIMAL:=5.7.1}
+: ${QT_MINIMAL:=5.9.4}
# @ECLASS-VARIABLE: FRAMEWORKS_MINIMAL
# @DESCRIPTION: