summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-12 13:10:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-12 15:20:41 +0200
commit764f4ee76e18cbe45f1f9ae924bac0aa2233c7ca (patch)
treef2f8fbad88b4fa91bd0314d1d3e5376edbecaae5
parentkde-apps/cervisia: 23.08.2 version bump (diff)
downloadgentoo-764f4ee76e18cbe45f1f9ae924bac0aa2233c7ca.tar.gz
gentoo-764f4ee76e18cbe45f1f9ae924bac0aa2233c7ca.tar.bz2
gentoo-764f4ee76e18cbe45f1f9ae924bac0aa2233c7ca.zip
kde-apps/dolphin-plugins-git: 23.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.08.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 9fe1e16111bc..180253a487a7 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-23.04.3.tar.xz 272912 BLAKE2B f0eb8bbab16d66f1e964131b436af7d3ae8febc26cf4fe394489a978c701ef2f5689bea7daf9eed8d7ef2f1f2bdba000a487cf7f0704ad30bd25e2d403ce5fae SHA512 8f487ba0bcbe561915064247ddb2327c3b7c8fa6ffc5c511d9c9ef37bd4f28a624533ce7a2da2a86b10b65f37915ca10840517872b40c2fd014cead6da5972c8
DIST dolphin-plugins-23.08.1.tar.xz 273396 BLAKE2B e65c161d992867c2934581ea3e92b457eddc30b193cdb92d49bc820b2d4a6069dc6b25f1fbfe0871ca6fe0548511ceb4a3045c8a0204a8a25a656bd030bb3fad SHA512 8266810d249c70e3c5e874d87caa4e2aa5960c7e35ecb39b39845f2e225adbccf6f92b3fce4e03a5383d3bbc13b140f039d7ba7678616a670e347f6798520a48
+DIST dolphin-plugins-23.08.2.tar.xz 273356 BLAKE2B 29820281a7bb703dcbd11d215e0a6d35aedc964778d443d826dd4636f87acbd4fd884745dd614981eeb9c3dd50ee2705f71883b261d600eb0a843045078d83f4 SHA512 a7f0a2109cd1793157ff5038cbda1ff219adcefa5e652a6ba0b3eeee674a460e918eaa71f4652460803ed18ef5834a1734b23939f155dd6b3e4247396dfe9b30
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.08.2.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.08.2.ebuild
new file mode 100644
index 000000000000..1b7ccaf9b170
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.08.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}