summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-14 02:41:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-15 14:08:22 +0100
commit767ad113f14b218323808e18eb715ceff42922a3 (patch)
tree8ddb65f334793d09dd507d7e9e908d63e7bec09d
parentlxde-base/lxlauncher: EAPI-7 bump, switch to GTK3 (diff)
downloadgentoo-767ad113f14b218323808e18eb715ceff42922a3.tar.gz
gentoo-767ad113f14b218323808e18eb715ceff42922a3.tar.bz2
gentoo-767ad113f14b218323808e18eb715ceff42922a3.zip
lxde-base/lxpanel: 0.10.1 version bump, EAPI-7, switch to GTK3
Bug: https://bugs.gentoo.org/769524 Closes: https://bugs.gentoo.org/708188 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--lxde-base/lxpanel/Manifest1
-rw-r--r--lxde-base/lxpanel/files/lxpanel-0.10.1-fix-pager-panel-width.patch37
-rw-r--r--lxde-base/lxpanel/lxpanel-0.10.1.ebuild71
3 files changed, 109 insertions, 0 deletions
diff --git a/lxde-base/lxpanel/Manifest b/lxde-base/lxpanel/Manifest
index b7063f60fc89..98ec09e4d49f 100644
--- a/lxde-base/lxpanel/Manifest
+++ b/lxde-base/lxpanel/Manifest
@@ -1 +1,2 @@
DIST lxpanel-0.10.0.tar.xz 1544700 BLAKE2B ea210feee23b2da1c9f6199bfc274c46e1142d6397ca0d1d8359329068ed6e46eaebff90fb220ce14121ed19cb5c60014230c7a7e42867318317845751418a7b SHA512 3e664eef3cf0f37cf4609f53f1f40f5d50e94ae088c497be0439851ea8f1426ef6ec1373d146e2e0ef1b9f51f557ae19eb5fb1059b0e5fcd5b1c49fd76207a59
+DIST lxpanel-0.10.1.tar.xz 1548276 BLAKE2B 2ea8628c9c4c7a77d65e58cae0b5656209db63b455299fcda00fe79aae1b139860ed8993ade7db68bbc65f61b8911f40879f1ef9993dc12f15f7480d3ea72cfa SHA512 0478ca1322a6645c5120e0fdb2b6d6409799f3296d971456670eb8b23b8457ae93a966ddcb5b5e5bdbcd694442ade2252d6a3931d36296e19e5339b2d689cfef
diff --git a/lxde-base/lxpanel/files/lxpanel-0.10.1-fix-pager-panel-width.patch b/lxde-base/lxpanel/files/lxpanel-0.10.1-fix-pager-panel-width.patch
new file mode 100644
index 000000000000..4d53fc8f783d
--- /dev/null
+++ b/lxde-base/lxpanel/files/lxpanel-0.10.1-fix-pager-panel-width.patch
@@ -0,0 +1,37 @@
+From b46e3a39786a5be04bf9cc3844dd184308cd7495 Mon Sep 17 00:00:00 2001
+From: Ben Walsh <b@wumpster.com>
+Date: Sat, 6 Jun 2020 10:38:15 +0100
+Subject: [PATCH] Specify GTK_REQUEST_CONSTANT_SIZE. Fixes #773.
+
+---
+ src/panel.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/src/panel.c b/src/panel.c
+index da9e718b..b52fc796 100644
+--- a/src/panel.c
++++ b/src/panel.c
+@@ -293,6 +293,12 @@ lxpanel_get_preferred_height (GtkWidget *widget,
+ if (natural_height)
+ *natural_height = requisition.height;
+ }
++
++static GtkSizeRequestMode
++lxpanel_get_request_mode (GtkWidget *widget)
++{
++ return GTK_SIZE_REQUEST_CONSTANT_SIZE;
++}
+ #endif
+
+ static void lxpanel_size_allocate(GtkWidget *widget, GtkAllocation *a)
+@@ -413,6 +419,7 @@ static void lxpanel_class_init(PanelToplevelClass *klass)
+ #if GTK_CHECK_VERSION(3, 0, 0)
+ widget_class->get_preferred_width = lxpanel_get_preferred_width;
+ widget_class->get_preferred_height = lxpanel_get_preferred_height;
++ widget_class->get_request_mode = lxpanel_get_request_mode;
+ #else
+ widget_class->size_request = lxpanel_size_request;
+ #endif
+--
+2.27.0
+
diff --git a/lxde-base/lxpanel/lxpanel-0.10.1.ebuild b/lxde-base/lxpanel/lxpanel-0.10.1.ebuild
new file mode 100644
index 000000000000..f8edfb798dc0
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.10.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1 xdg
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="https://wiki.lxde.org/en/LXPanel"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+alsa wifi"
+
+RDEPEND="
+ dev-libs/keybinder:3
+ lxde-base/lxmenu-data
+ >=lxde-base/menu-cache-1.1.0-r1
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ >=x11-libs/libfm-1.3.2[gtk]
+ x11-libs/libwnck:3
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXpm
+ alsa? ( media-libs/alsa-lib )
+ wifi? ( net-wireless/wireless-tools )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="If you have problems with broken icons shown in the main panel,
+you will have to configure panel settings via its menu.
+This will not be an issue with first time installations."
+
+PATCHES=(
+ # https://sourceforge.net/p/lxde/bugs/773/
+ "${FILESDIR}/${P}-fix-pager-panel-width.patch"
+)
+
+src_configure() {
+ local plugins="netstatus,volume,cpu,deskno,batt,kbled,xkb,thermal,cpufreq,monitors"
+
+ use wifi && plugins+=",netstat"
+ use alsa && plugins+=",volumealsa"
+ [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
+
+ econf \
+ $(use_enable alsa) \
+ --enable-gtk3 \
+ --with-x \
+ --with-plugins="${plugins}"
+ # the gtk+ dep already pulls in libX11, so we might as well hardcode with-x
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}