summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 23:14:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 23:22:58 +0200
commit76857017764fc54e572e9e71c34653d156485813 (patch)
tree71b0b93d7461c4157bad395fb924850dc366f6f6
parentnet-libs/libquotient: Drop 0.6.5 (diff)
downloadgentoo-76857017764fc54e572e9e71c34653d156485813.tar.gz
gentoo-76857017764fc54e572e9e71c34653d156485813.tar.bz2
gentoo-76857017764fc54e572e9e71c34653d156485813.zip
app-text/kjots: Drop 5.0.2-r2
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/kjots/Manifest1
-rw-r--r--app-text/kjots/files/kjots-5.0.2-kf5bookmarks-5.69.patch67
-rw-r--r--app-text/kjots/files/kjots-5.0.2-kontactinterface-20.08.patch148
-rw-r--r--app-text/kjots/kjots-5.0.2-r2.ebuild49
4 files changed, 0 insertions, 265 deletions
diff --git a/app-text/kjots/Manifest b/app-text/kjots/Manifest
index 46c3940ca963..ce9d679bdbbc 100644
--- a/app-text/kjots/Manifest
+++ b/app-text/kjots/Manifest
@@ -1,2 +1 @@
-DIST kjots-5.0.2.tar.xz 230608 BLAKE2B 3194b0ef072decfa09455ca7e8d6057ea3f37f54d37641a6ddf28e17ef4662a408adc9e9b04394e6002b51e72ef740412bcdd70324d6efcb9e949f9911437559 SHA512 a652765c56cebcaeba7b879cc075555c28667abdba84d11e986e5ffb440fbc776116f363992dd84d939918ae7d80ef5c2e1093da28d114b18041e10e5209b225
DIST kjots-5.1.0.tar.xz 184972 BLAKE2B 28bea486bcaa552b7463f9a2132230d5729ade7a2eadb06f66f958c660117bd3a1976d6da14f1339abfbd39930708fe77ae923042a0bc8ca59bf074e409375ae SHA512 71c30e0810157cf3d039e683d368cfa9fa3ec88918eee2d85477a9eb9f073af43dfb2318957019f35503d484e2521289bcb043ff9bfc2822eb900a2f5b8d5d62
diff --git a/app-text/kjots/files/kjots-5.0.2-kf5bookmarks-5.69.patch b/app-text/kjots/files/kjots-5.0.2-kf5bookmarks-5.69.patch
deleted file mode 100644
index 63bda683122f..000000000000
--- a/app-text/kjots/files/kjots-5.0.2-kf5bookmarks-5.69.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From ca6f4b963e83ed91cc7314e1b60fe6607b61b53e Mon Sep 17 00:00:00 2001
-From: Igor Poboiko <igor.poboiko@gmail.com>
-Date: Sun, 12 Apr 2020 17:55:24 +0300
-Subject: [KJots] Fix bookmarks actions
-
-Summary:
-This patch ports KJots from deprecated `KBookmarksMenu` API (see {D25660}).
-
-On my machine, it also fixes a crash (`bm_action` was null for some reason,
-I did not investigate it though).
-
-It also fixes the shortcuts collision (`action->setShortcut` was not enough,
-one also needs to run `actionCollection->setDefaultShortcut`).
-
-BUG: 384000
-
-Test Plan:
-1) Start KJots
-2) It don't crash, and `Ambiguous shortcuts` dialog does not appear)
-3) Open `Bookmarks` menu, the shortcut is `Ctrl+Shift+B`.
-
-Reviewers: dvratil
-
-Reviewed By: dvratil
-
-Subscribers: winterz, kde-pim
-
-Tags: #kde_pim
-
-Differential Revision: https://phabricator.kde.org/D28775
----
- src/kjotswidget.cpp | 13 ++++++++-----
- 1 file changed, 8 insertions(+), 5 deletions(-)
-
-diff --git a/src/kjotswidget.cpp b/src/kjotswidget.cpp
-index 865129b..e343bbd 100644
---- a/src/kjotswidget.cpp
-+++ b/src/kjotswidget.cpp
-@@ -353,17 +353,20 @@ KJotsWidget::KJotsWidget(QWidget *parent, KXMLGUIClient *xmlGuiClient, Qt::Windo
- bookmarkMenu = actionCollection->add<KActionMenu>(QLatin1String("bookmarks"));
- bookmarkMenu->setText(i18n("&Bookmarks"));
- KJotsBookmarks *bookmarks = new KJotsBookmarks(treeview);
-- /*KBookmarkMenu *bmm =*/ new KBookmarkMenu(
-+ KBookmarkMenu *bmm = new KBookmarkMenu(
- KBookmarkManager::managerForFile(
- QStandardPaths::standardLocations(QStandardPaths::AppDataLocation).first() + QStringLiteral("/kjots/bookmarks.xml"),
- QStringLiteral("kjots")),
-- bookmarks, bookmarkMenu->menu(), actionCollection);
-+ bookmarks, bookmarkMenu->menu());
-
- // "Add bookmark" and "make text bold" actions have conflicting shortcuts (ctrl + b)
- // Make add_bookmark use ctrl+shift+b to resolve that.
-- QAction *bm_action = qobject_cast<QAction *>(actionCollection->action(QLatin1String("add_bookmark")));
-- Q_ASSERT(bm_action);
-- bm_action->setShortcut(Qt::CTRL + Qt::SHIFT + Qt::Key_B);
-+ QAction *bm_action = bmm->addBookmarkAction();
-+ actionCollection->addAction(QStringLiteral("add_bookmark"), bm_action);
-+ actionCollection->setDefaultShortcut(bm_action, Qt::CTRL | Qt::SHIFT | Qt::Key_B);
-+ actionCollection->addAction(QStringLiteral("edit_bookmark"), bmm->editBookmarksAction());
-+ actionCollection->addAction(QStringLiteral("add_bookmarks_list"), bmm->bookmarkTabsAsFolderAction());
-+
-
- KStandardAction::find(this, SLOT(onShowSearch()), actionCollection);
- action = KStandardAction::findNext(this, SLOT(onRepeatSearch()), actionCollection);
---
-cgit v1.1
-
diff --git a/app-text/kjots/files/kjots-5.0.2-kontactinterface-20.08.patch b/app-text/kjots/files/kjots-5.0.2-kontactinterface-20.08.patch
deleted file mode 100644
index 608a50d98567..000000000000
--- a/app-text/kjots/files/kjots-5.0.2-kontactinterface-20.08.patch
+++ /dev/null
@@ -1,148 +0,0 @@
-From bcf49fb95bee12bbc4bef0578285ad296deafcae Mon Sep 17 00:00:00 2001
-From: David Faure <faure@kde.org>
-Date: Fri, 24 Apr 2020 01:25:43 +0200
-Subject: [PATCH] Install the kontact plugin into kontact5, with JSON metadata.
-
-Summary: This will allow kontact to use KPluginLoader one day.
-
-It also fixes compilation with current kontactinterface API.
-
-Test Plan:
-rm $prefix/lib64/plugins/kontact_zanshinplugin.so ; make install
-kontact still finds the zanshin plugin
-
-The same steps (other than old-kontact-interface compatibility) were already
-pushed to all other kontact plugins.
-
-This commit is very similar to https://phabricator.kde.org/D28847
-and its predecessor commit, in zanshin.
----
- src/kontact_plugin/CMakeLists.txt | 11 ++++++++-
- src/kontact_plugin/kjots_plugin.cpp | 34 ++++++++++++++++++++------
- src/kontact_plugin/kjots_plugin.h | 5 ++++
- src/kontact_plugin/kjotsplugin.desktop | 2 +-
- 4 files changed, 43 insertions(+), 9 deletions(-)
-
-diff --git a/src/kontact_plugin/CMakeLists.txt b/src/kontact_plugin/CMakeLists.txt
-index 8a6b5e1..dec4b8b 100644
---- a/src/kontact_plugin/CMakeLists.txt
-+++ b/src/kontact_plugin/CMakeLists.txt
-@@ -1,13 +1,22 @@
- include_directories(${kjots_SOURCE_DIR}/src)
-
-+# TODO: remove once kontactinterface 5.14.42 is required
-+if(NOT CMAKE_VERSION VERSION_LESS "3.10.0")
-+ # CMake 3.9+ warns about automoc on files without Q_OBJECT, and doesn't know about other macros.
-+ # 3.10+ lets us provide more macro names that require automoc.
-+ # KF5 >= 5.42 takes care itself of adding its macros in its cmake config files
-+ list(APPEND CMAKE_AUTOMOC_MACRO_NAMES "EXPORT_KONTACT_PLUGIN_WITH_JSON")
-+endif()
-+
- set(kontact_kjots_PART_SRCS
- kjots_plugin.cpp
- )
-
- add_library(kontact_kjotsplugin MODULE ${kontact_kjots_PART_SRCS})
- target_link_libraries(kontact_kjotsplugin KF5::KontactInterface)
-+kcoreaddons_desktop_to_json(kontact_kjotsplugin kjotsplugin.desktop)
-
--install(TARGETS kontact_kjotsplugin DESTINATION ${KDE_INSTALL_PLUGINDIR})
-+install(TARGETS kontact_kjotsplugin DESTINATION ${KDE_INSTALL_PLUGINDIR}/kontact5)
- install(FILES kjotsplugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/kontact)
- install(FILES kjots.setdlg DESTINATION ${KDE_INSTALL_DATADIR}/kontact/ksettingsdialog)
-
-diff --git a/src/kontact_plugin/kjots_plugin.cpp b/src/kontact_plugin/kjots_plugin.cpp
-index 66e7ed5..b74d601 100644
---- a/src/kontact_plugin/kjots_plugin.cpp
-+++ b/src/kontact_plugin/kjots_plugin.cpp
-@@ -33,7 +33,25 @@
- #include <QIcon>
- #include <QStandardPaths>
-
--EXPORT_KONTACT_PLUGIN(KJotsPlugin, kjots)
-+#if KONTACTINTERFACE_VERSION < QT_VERSION_CHECK(5, 14, 42)
-+/**
-+ Exports Kontact plugin.
-+ @param pluginclass the class to instanciate (must derive from KontactInterface::Plugin
-+ @param jsonFile filename of the JSON file, generated from a .desktop file
-+ */
-+#define EXPORT_KONTACT_PLUGIN_WITH_JSON( pluginclass, jsonFile ) \
-+ class Instance \
-+ { \
-+ public: \
-+ static QObject *createInstance( QWidget *, QObject *parent, const QVariantList &list ) \
-+ { return new pluginclass( static_cast<KontactInterface::Core*>( parent ), list ); } \
-+ }; \
-+ K_PLUGIN_FACTORY_WITH_JSON( KontactPluginFactory, jsonFile, registerPlugin< pluginclass > \
-+ ( QString(), Instance::createInstance ); ) \
-+ K_EXPORT_PLUGIN_VERSION(KONTACT_PLUGIN_VERSION)
-+#endif
-+
-+EXPORT_KONTACT_PLUGIN_WITH_JSON(KJotsPlugin, "kjotsplugin.json")
-
- KJotsPlugin::KJotsPlugin(KontactInterface::Core *core, const QVariantList &)
- : KontactInterface::Plugin(core, core, "kjots")
-@@ -63,15 +81,17 @@ QStringList KJotsPlugin::invisibleToolbarActions() const
- return { QStringLiteral("new_page"), QStringLiteral("new_book") };
- }
-
-+#if KONTACTINTERFACE_VERSION >= QT_VERSION_CHECK(5, 14, 42)
-+KParts::Part *KJotsPlugin::createPart()
-+{
-+ return loadPart();
-+}
-+#else
- KParts::ReadOnlyPart *KJotsPlugin::createPart()
- {
-- KParts::ReadOnlyPart *part = loadPart();
-- if (!part) {
-- return Q_NULLPTR;
-- }
--
-- return part;
-+ return loadPart();
- }
-+#endif
-
- QStringList KJotsPlugin::configModules() const
- {
-diff --git a/src/kontact_plugin/kjots_plugin.h b/src/kontact_plugin/kjots_plugin.h
-index cd62373..4945d25 100644
---- a/src/kontact_plugin/kjots_plugin.h
-+++ b/src/kontact_plugin/kjots_plugin.h
-@@ -24,6 +24,7 @@
- #define KJOTS_PLUGIN_H
-
- #include <KontactInterface/UniqueAppHandler>
-+#include <kontactinterface_version.h>
-
- namespace KontactInterface
- {
-@@ -62,7 +63,11 @@ public:
- QStringList invisibleToolbarActions() const Q_DECL_OVERRIDE;
-
- protected:
-+#if KONTACTINTERFACE_VERSION >= QT_VERSION_CHECK(5, 14, 42)
-+ KParts::Part *createPart() override;
-+#else
- KParts::ReadOnlyPart *createPart() Q_DECL_OVERRIDE;
-+#endif
- KontactInterface::UniqueAppWatcher *mUniqueAppWatcher;
-
- private:
-diff --git a/src/kontact_plugin/kjotsplugin.desktop b/src/kontact_plugin/kjotsplugin.desktop
-index 1339753..d5a198f 100644
---- a/src/kontact_plugin/kjotsplugin.desktop
-+++ b/src/kontact_plugin/kjotsplugin.desktop
-@@ -3,7 +3,7 @@ Type=Service
- Icon=kjots
- X-KDE-ServiceTypes=Kontact/Plugin,KPluginInfo
-
--X-KDE-Library=kontact_kjotsplugin
-+X-KDE-Library=kontact5/kontact_kjotsplugin
- X-KDE-KontactPluginVersion=10
- X-KDE-KontactPartLibraryName=kjotspart
- X-KDE-KontactPartExecutableName=kjots
---
-GitLab
-
diff --git a/app-text/kjots/kjots-5.0.2-r2.ebuild b/app-text/kjots/kjots-5.0.2-r2.ebuild
deleted file mode 100644
index 07aaf94d7b1c..000000000000
--- a/app-text/kjots/kjots-5.0.2-r2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-KFMIN=5.70.0
-QTMIN=5.12.3
-inherit ecm kde.org
-
-DESCRIPTION="Note taking utility by KDE"
-HOMEPAGE="https://userbase.kde.org/KJots https://community.kde.org/PIM/KJots"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="5"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-libs/grantlee:5
- dev-libs/libxslt
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtprintsupport-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=kde-apps/akonadi-20.08.1:5
- >=kde-apps/akonadi-notes-20.08.1:5
- >=kde-apps/kmime-20.08.1:5
- >=kde-apps/kontactinterface-20.08.1:5
- >=kde-apps/kpimtextedit-20.08.1:5
- >=kde-frameworks/kbookmarks-${KFMIN}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kitemmodels-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES+=(
- "${FILESDIR}/${P}-kf5bookmarks-5.69.patch" # KDE-Bug 384000
- "${FILESDIR}/${P}-kontactinterface-20.08.patch"
-)