summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 09:08:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 10:12:05 +0200
commit7685ab73de5e31101ff83b44b1398d8d49b4d08f (patch)
treee6677fa0ab81b995ddccb170c9444f2dd459a468
parentdev-ruby/globalid: keyword 1.0.0-r1 for ~ppc, ~ppc64 (diff)
downloadgentoo-7685ab73.tar.gz
gentoo-7685ab73.tar.bz2
gentoo-7685ab73.zip
dev-python/identify: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index b3dbad5b2436..850de231ad30 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1 +1,2 @@
DIST identify-2.4.12.gh.tar.gz 101366 BLAKE2B 55c1b7642d3f273beb415fabc683bfff46c1039fcf146d7c9c09f53b2beffab82e5e687849cbae6b7d2d9d0502a340e635ced730afa6610d20d75f0412943635 SHA512 8b9554a0a726e6fd25ca0fe1031b0a8a114fe98e13e41e73ad6549495a0dc02a2047c151f7717d8df705aba661e11ab1c0e48eff0bcf4d2a0dcff00f5ace1eec
+DIST identify-2.5.0.gh.tar.gz 101367 BLAKE2B f927861976aaa2c53e5bd131b84f299c7290111e18a167040298784ebc3b562180b69d4a22661c858e7e56abde69c2e0fd5048c023d0c84af069748a85ccc4fb SHA512 d7b9d7b31262fdb97fdb16caea01ae0e0e0cee2b5a10b0224b53b84842c3c1e0e1914829bc89439718ae25c68cfde23328f79780b847087d445bdbf3a64aef1b
diff --git a/dev-python/identify/identify-2.5.0.ebuild b/dev-python/identify/identify-2.5.0.ebuild
new file mode 100644
index 000000000000..d1f325c14ca4
--- /dev/null
+++ b/dev-python/identify/identify-2.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest