summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcos Rodrigues Gonzalez <mrgonzalez1275@gmail.com>2020-08-19 21:26:57 -0300
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 17:11:17 +0300
commit7688eb6170421f95099fc27818281b3eb4aa2aae (patch)
tree06c8e8791bb711584fd35679c58731de8e7feb61
parentapp-crypt/tpm2-abrmd: Remove old (diff)
downloadgentoo-7688eb61.tar.gz
gentoo-7688eb61.tar.bz2
gentoo-7688eb61.zip
dev-util/packer: Version bump to 1.5.6
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Marcos Rodrigues Gonzalez <mrgonzalez1275@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17177 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-util/packer/Manifest1
-rw-r--r--dev-util/packer/packer-1.5.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/packer/Manifest b/dev-util/packer/Manifest
index 5a397482b258..9910602b85d6 100644
--- a/dev-util/packer/Manifest
+++ b/dev-util/packer/Manifest
@@ -3,3 +3,4 @@ DIST packer-1.4.0.tar.gz 9794922 BLAKE2B 2e1d817e0a3f549255ecd8693d6d99b2e45df2e
DIST packer-1.4.1.tar.gz 11279518 BLAKE2B 7b1b966af8cac73826fc8f5a1cb39183fd2ae1d3b7da6d7408cbb7c3342a0fd2ba84cf1df89ea9edc41353c0bbb6c874347745a91c3eaa1a742521c79500f21a SHA512 4038990655eecf412be9dae9edd09a300543a3b0b841c982631cb48f4905388f9dbf26a9b0ac3cb77628d1e650600b7d3b89a1694f746dfdef086a621078cde1
DIST packer-1.4.4.tar.gz 12811202 BLAKE2B 7a59f0252ac3d8158d64806e54fe459fe154bdc11b67539e4a39e7c79273bba6c5814cec0128c177a51e48bcf9172692d3eb3c7e789b768019c329c111fd5a0c SHA512 c4d2ca049b442fbbc65214ae75f5c85dc87b09eac8711891c4678ff3b2a676d00a051c08448a7a99b7a0977d4a04ad8bc559fd09885b520e6a8eb2dfc33ba50a
DIST packer-1.4.5.tar.gz 13705057 BLAKE2B d23527e8bb0104e3f0206f5a82eb93fbe15a9542409bcce13cefd49fa83a47c0262f48e74ff951990211de9f85fc32efd41bbd4ed286b3462aed86df68afebc8 SHA512 b2a3ae27612c78fcfcb2ac655437faf2cff6e587fd10033b39ddaca8b92b634b93ecd0ae7e3ee43253ee716a2c0f7da532b3ae0ce33c59d1d3896f9187d9a657
+DIST packer-1.5.6.tar.gz 16037500 BLAKE2B 9409aad981b3494a442fc6854481853494b12b74532ed3ac8d210d4e275a8f4f18bfb6dcfd7c36c4e97b3d5ba0263155fc8f08592b0123705c5d341d9183e6eb SHA512 993f54a1bf98abd5bc450bafaf202fbbfbad009b661d49783ff82cba9891b8556340801680c0fdc33b90396a3101a2ed93a11798ad51c10d7bd5f81fef4f5a31
diff --git a/dev-util/packer/packer-1.5.6.ebuild b/dev-util/packer/packer-1.5.6.ebuild
new file mode 100644
index 000000000000..c1237d3214bd
--- /dev/null
+++ b/dev-util/packer/packer-1.5.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 icu imagemagick ISC JSON MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+ go build \
+ -mod=vendor \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}