summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-01 02:10:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-01 02:29:36 +0100
commit76a6a77edea77a1b9ec18ce2b751c73f1b30f863 (patch)
treecf598b76f8ca1edcfd4abf457c47901a66f1d65c
parentdev-python/pygments: Bump to 2.11.1 (diff)
downloadgentoo-76a6a77e.tar.gz
gentoo-76a6a77e.tar.bz2
gentoo-76a6a77e.zip
dev-python/python-utils: Bump to 2.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-2.7.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index c4faa5926ad1..d412cc4e6bc7 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1,3 +1,4 @@
DIST python-utils-2.5.6.tar.gz 14057 BLAKE2B 2f66ab26cd6cda25f73c9f40081048404cde819e3e3c2fd11d134244ab2b80a05ab2b943e56a45bd8656bf3ba231853e3bfa9efbab9cb70515daaec70f6e0715 SHA512 35299880afdecd4a44144b95e6b2073e51680dfd2b00f31fb333d578cfa2c2f8bf5f58128cab88a7b81e658e6d5dca303f1c9f5be3870160679e1defbf94859e
DIST python-utils-2.6.0.tar.gz 14885 BLAKE2B 089d7a57a8469968bed147a01907f35d1430349130e0f7152bbd38dd65053cf3d6424942eee8cc9006baaec5f13bffcbef81bd8723cad7ee03b1358a5c2d3d27 SHA512 a582558e38342f54f7c1eda1f9038728dd5904729aaec4e5719e56bb447bc6fcb93bf5ea3af134ce245eda059b9be81d15b268165cbc10799ba112fc157f939b
DIST python-utils-2.6.3.tar.gz 14914 BLAKE2B 6df19348feba000dccc516704db38af299613c70505cd7fa16a2e37c4a46b1cff7ee9bf164be13da33a3b4eb6b9577b76202bfbffdaed47b1b7b60e948d349ac SHA512 3c5834976408eae6b37aa07581960ee5511765f9ea1e6347523465a93ca801bc2d71f785a73a2050706dad2c09ffcfb5227715a9b4d0700904d31eb1295b30b6
+DIST python-utils-2.7.0.tar.gz 27743 BLAKE2B 5cd0671ad1e003932aed0bf0b69326d907013d3f739e833f218600ee056d76bc87dd2a424f5459654de30dacc3378c14f10af1664344ac66813410d261718c61 SHA512 3401c9ad2e4933d0d40d4bc90f1dbe212e672289e7239a4a46d79a04e80f85bb0def67324f0184ca397ec3708cb935839ffe922a202de9c911198ea86d88e2c5
diff --git a/dev-python/python-utils/python-utils-2.7.0.ebuild b/dev-python/python-utils/python-utils-2.7.0.ebuild
new file mode 100644
index 000000000000..151ae849531a
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3)
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--flake8/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}