summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-09 16:01:36 +0000
committerSam James <sam@gentoo.org>2020-09-09 16:01:36 +0000
commit76c1cf9aa7fd7da4311612199fd09ed9caff0290 (patch)
tree8eab1938bb32ff52795ad5985f9c19c3bdb2e594
parentnet-im/bitlbee: security cleanup (diff)
downloadgentoo-76c1cf9aa7fd7da4311612199fd09ed9caff0290.tar.gz
gentoo-76c1cf9aa7fd7da4311612199fd09ed9caff0290.tar.bz2
gentoo-76c1cf9aa7fd7da4311612199fd09ed9caff0290.zip
dev-util/global: security cleanup
Bug: https://bugs.gentoo.org/646348 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/global/Manifest2
-rw-r--r--dev-util/global/global-6.3.1.ebuild81
-rw-r--r--dev-util/global/global-6.5.7.ebuild96
3 files changed, 0 insertions, 179 deletions
diff --git a/dev-util/global/Manifest b/dev-util/global/Manifest
index 902af58d5dc5..40b667bfa42e 100644
--- a/dev-util/global/Manifest
+++ b/dev-util/global/Manifest
@@ -1,3 +1 @@
-DIST global-6.3.1.tar.gz 1369634 BLAKE2B 8d93222ccbb4a45c0b9f114cd84b342b3f6ab99f7e0bbc18bfe00912ecd53f606be9d32fce1570e027009fd1fbe4752f03dd19c183dfda438d67a329808a6b45 SHA512 83becd6cda06f8da17ea0c701bb135523ff48cec73b233d24566387d11a35c0b42f410b62753838e2b364a5a485cac033b4aef1159cc6f4cdeca4a7b6c5bb4d6
-DIST global-6.5.7.tar.gz 2940567 BLAKE2B e0c692e09f9f7ea64ecbe47e18691efd3c641f28826e19751fb812690cd9d64a53af03055de9ec8199637da46dbd6084fec16380d7f295c83ed77553a8e301fd SHA512 0d33f718839e5e00bdd6d042b415a69c5e1f232d843610870505f8f20635b445810149b1b84ea8b77881f5f64814783ebe3cdcab2f84b8a085223b64293a9045
DIST global-6.6.4.tar.gz 2988969 BLAKE2B 784087537094d27c10d1f2bc992e799c35ab6ce3b86e041c31279e6954b203e80676b3158ba95e7957456b75a213d70998aae9047836cd4d388212236f05a081 SHA512 cb4ed451d3aaf47c4c59cdc3f74c97d3171108177d4846b5dac843589710e66d87c9d7bbe080c3770329e8e40105ac52dcafb4609257347593cca4d94711f483
diff --git a/dev-util/global/global-6.3.1.ebuild b/dev-util/global/global-6.3.1.ebuild
deleted file mode 100644
index 9d48ee787d89..000000000000
--- a/dev-util/global/global-6.3.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit autotools elisp-common eutils ltprune
-
-DESCRIPTION="tag system to find an object location in various sources"
-HOMEPAGE="https://www.gnu.org/software/global/global.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="doc emacs vim"
-
-RDEPEND="|| ( dev-libs/libltdl:0 sys-devel/libtool:2 )
- sys-libs/ncurses
- emacs? ( >=app-editors/emacs-23.1:* )
- vim? ( || ( app-editors/vim app-editors/gvim ) )"
-DEPEND="${DEPEND}
- doc? ( app-text/texi2html sys-apps/texinfo )"
-
-SITEFILE="50gtags-gentoo.el"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-6.2.9-tinfo.patch"
- eautoreconf
-}
-
-src_configure() {
- econf "$(use_with emacs lispdir "${SITELISP}/${PN}")"
-}
-
-src_compile() {
- if use doc; then
- texi2pdf -q -o doc/global.pdf doc/global.texi
- texi2html -o doc/global.html doc/global.texi
- fi
-
- if use emacs; then
- elisp-compile *.el
- fi
-
- emake
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if use doc; then
- dohtml doc/global.html
- # doc/global.pdf is generated if tex executable (e.g. /usr/bin/tex) is available.
- [[ -f doc/global.pdf ]] && dodoc doc/global.pdf
- fi
-
- dodoc AUTHORS FAQ NEWS README THANKS
-
- insinto /etc
- doins gtags.conf
-
- if use vim; then
- insinto /usr/share/vim/vimfiles/plugin
- doins gtags.vim
- fi
-
- if use emacs; then
- elisp-install ${PN} *.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- prune_libtool_files
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/global/global-6.5.7.ebuild b/dev-util/global/global-6.5.7.ebuild
deleted file mode 100644
index 2b19aa0f759f..000000000000
--- a/dev-util/global/global-6.5.7.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools ltprune elisp-common
-
-DESCRIPTION="tag system to find an object location in various sources"
-HOMEPAGE="https://www.gnu.org/software/global/global.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc emacs vim"
-
-RDEPEND="
- sys-libs/ncurses
- emacs? ( >=app-editors/emacs-23.1:* )
- vim? ( || (
- app-editors/vim
- app-editors/gvim
- )
- )
- || (
- dev-libs/libltdl:0
- sys-devel/libtool:2
- )"
-
-DEPEND="${DEPEND}
- doc? (
- app-text/texi2html
- sys-apps/texinfo
- )"
-
-SITEFILE="50gtags-gentoo.el"
-
-PATCHES=( "${FILESDIR}/${PN}-6.2.9-tinfo.patch" )
-
-DOCS=( AUTHORS FAQ NEWS README THANKS )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- "$(use_with emacs lispdir "${SITELISP}/${PN}")"
-}
-
-src_compile() {
- if use doc; then
- texi2pdf -q -o doc/global.pdf doc/global.texi
- texi2html -o doc/global.html doc/global.texi
- fi
-
- if use emacs; then
- elisp-compile *.el
- fi
-
- emake
-}
-
-src_install() {
- default
-
- insinto /etc
- doins gtags.conf
-
- if use vim; then
- insinto /usr/share/vim/vimfiles/plugin
- doins gtags.vim
- fi
-
- if use emacs; then
- elisp-install ${PN} *.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use doc; then
- # doc/global.pdf is generated if tex executable (e.g. /usr/bin/tex) is available.
- [[ -f doc/global.pdf ]] && DOCS+=( doc/global.pdf )
- fi
-
- einstalldocs
- prune_libtool_files
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}