summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-17 09:01:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-17 09:28:52 +0200
commit76ce70859bdaf6654ea2cf5323488e12df40e1a1 (patch)
tree7da0ad7a1222fa46f942a58b29c4731fdd93c94d
parentdev-python/requests-cache: Bump to 0.7.4 (diff)
downloadgentoo-76ce70859bdaf6654ea2cf5323488e12df40e1a1.tar.gz
gentoo-76ce70859bdaf6654ea2cf5323488e12df40e1a1.tar.bz2
gentoo-76ce70859bdaf6654ea2cf5323488e12df40e1a1.zip
dev-python/moto: Bump to 2.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-2.2.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 8aef62d6f041..f50448c1a10e 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -2,3 +2,4 @@ DIST moto-2.0.10.tar.gz 1629239 BLAKE2B 3b1e2272f0a78b90dcf4263fa9e1e7cee1762121
DIST moto-2.0.5.tar.gz 1551415 BLAKE2B 452cb94443188e1715145bee574f04924d894a3d647673443a8a335bb907f8601098540b032d6c9a8ced3e1fc490c49ad70c877547d905cece05bbb742d05976 SHA512 70e64ab98873d480e776a2139a4d351665c6c2f98faf90e2871c6b9998571d1bd239757bc90bbc6ab6e1ed510598bfce77157ad522953efe40c884068885c57d
DIST moto-2.2.0.tar.gz 1650655 BLAKE2B 9969de2fb323b2deb272eb47727884054a35827a5db382f83a4177cf6cac5339f89164d05c288a977bc1895a204d13d02069e8b37880ea3d04374f6ed4d6be47 SHA512 7eabb515f94920af9b8f028afaaa51e27983f7bfd73f66c29fc191e2f3dd3e8939ddac67de0127c67c35cbc17c3500a7390103b26c85056780c865aadeb5e1d9
DIST moto-2.2.2.tar.gz 1684678 BLAKE2B ebe1eb08c67ccdb8c484fa8fc75d7ce58750d94620f46b53268d6b6b0732d90160bf7b6837efa492f621e1c001d933f5d59d39c266d65bbb1852f315b3bc03d0 SHA512 a8b192637b701eda0e4a7b11e84f5251386de98590f1d7c33732d8bf12642b39b61f1d360ad39c3e1b0a645268139d9e330d48fbe7029b943094ad317cb45ff6
+DIST moto-2.2.3.tar.gz 1700636 BLAKE2B 926fe245ce457dd79eef6780fc0b984d2ff1cbe95807a3463f0d0080583af2ba356ccfcce22e60927737e1531ec7bc167c5f649e784b191ec821aa56df65277d SHA512 0b46229ae06db7cb2634df3f1b3b1a6b6fc983978a763e8879db0d9e209ccc6b96b28e8e2ee40f6e1a8e39b74d7a2430788126220e3a7dab5e8df217c3c8c005
diff --git a/dev-python/moto/moto-2.2.3.ebuild b/dev-python/moto/moto-2.2.3.ebuild
new file mode 100644
index 000000000000..e01d705cfed1
--- /dev/null
+++ b/dev-python/moto/moto-2.2.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-tempfile[${PYTHON_USEDEP}]' python3_{6,7})
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-python-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ dev-python/dicttoxml[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.9.201[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.12.201[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unpin indirect dep on ecdsa that's supposed to workaround pip bugs
+ sed -i -e '/ecdsa/s:<0.15::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local ignore=(
+ # incompatible versions?
+ tests/test_core/test_decorator_calls.py
+ tests/test_s3/test_s3_classdecorator.py
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network' ${ignore[@]/#/--ignore }
+}