summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-06-29 09:08:18 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-06-29 09:08:23 +0100
commit76d1bcce1976b7019adf8cb6a60d584561bc274d (patch)
tree3aeab77fa59957a04285c9dbc0fbb8ae49c42ada
parenteclass/prefix: add support for EAPI=8 (diff)
downloadgentoo-76d1bcce1976b7019adf8cb6a60d584561bc274d.tar.gz
gentoo-76d1bcce1976b7019adf8cb6a60d584561bc274d.tar.bz2
gentoo-76d1bcce1976b7019adf8cb6a60d584561bc274d.zip
dev-haskell/snap-core: require io-streamz[zlib]
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/799182 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/snap-core/snap-core-1.0.4.2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-haskell/snap-core/snap-core-1.0.4.2.ebuild b/dev-haskell/snap-core/snap-core-1.0.4.2.ebuild
index 0a9b8c777f02..0d7046af4b4e 100644
--- a/dev-haskell/snap-core/snap-core-1.0.4.2.ebuild
+++ b/dev-haskell/snap-core/snap-core-1.0.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,13 +18,16 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="debug portable"
+# Fixed in next release: https://github.com/snapframework/snap-core/commit/49a8090d7834a0ef9b438048e96be36e55b2fbf5
+RESTRICT=test # test relied on headers ordering
+
RDEPEND=">=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
>=dev-haskell/bytestring-builder-0.10.4:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
>=dev-haskell/case-insensitive-1.1:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
>=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/hashable-1.2.0.6:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
>=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
- >=dev-haskell/io-streams-1.3:=[profile?] <dev-haskell/io-streams-1.6:=[profile?]
+ >=dev-haskell/io-streams-1.3:=[zlib,profile?] <dev-haskell/io-streams-1.6:=[zlib,profile?]
>=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
>=dev-haskell/monad-control-1.0:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
>=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]