summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-11 08:51:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-11 09:56:44 +0200
commit76e8eaff576945f20b8198421db78991f4a16d9f (patch)
treedffa09a1a79af398e059f5e7de3c2b26c9395039
parentdev-python/zeroconf: Bump to 0.36.8 (diff)
downloadgentoo-76e8eaff576945f20b8198421db78991f4a16d9f.tar.gz
gentoo-76e8eaff576945f20b8198421db78991f4a16d9f.tar.bz2
gentoo-76e8eaff576945f20b8198421db78991f4a16d9f.zip
dev-python/moto: Bump to 2.2.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-2.2.9.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 62910599a49a..0258cfa00948 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -6,3 +6,4 @@ DIST moto-2.2.3.tar.gz 1700636 BLAKE2B 926fe245ce457dd79eef6780fc0b984d2ff1cbe95
DIST moto-2.2.4.tar.gz 1724663 BLAKE2B 3feb39bec246a8157aa542c711289ab0ca257ec510835cd48aa732c3f07903db857971e3d024c1aef35b5a0b55b7c4ecef2b319824c1d76f0076ab8d2d75329e SHA512 8acd8a3156db71af35ad0ac6a5105a6b7739d8ca9881a2cb091637830bc6fbb10d8bf6adfd1a1091556f9269fad737b345d2bdf50e09b54201fe7438674dd906
DIST moto-2.2.5.tar.gz 1737336 BLAKE2B 450861edc607b9175cd72f29923e3259b81ce3a6e02302eb74486946cd8f6ebe8c15c61f6fd6da66d821b148924a0de1bcaf4e46ce6a5a751f7817d42450ea96 SHA512 27c04690d55647c7b43b342647f9a37f47ec3656c96aad8b6572c57752d555a77ecce3670e3cc5397318423ed179632fd79562a8b3a209049d74bf6e2a4bd51d
DIST moto-2.2.6.tar.gz 1750177 BLAKE2B 0ea94b8a46e212bbf6556c1fc1ec439ea83f1d1dbbaea2e494d58c3f33e68c8397a243b19de45f4ef500482d510a0f2bf99bd9a85e784b02e7c174be3de4e0c9 SHA512 562e43f0d323a16c6a1fc69775b82c904c8a89df528a5ca4b383288d3749c15482f80befdb261bfd30de978f45ae4b6cbca4ffe33391dfcee8002ea604741b60
+DIST moto-2.2.9.tar.gz 1879730 BLAKE2B 483b25d0ef7d14de351f2b15ec83dc05339897e02611d8c48c49e28453a75a96748d7fe4d522a8372de243151443f1bf4a8eaf1cfe962e795270f58439357db9 SHA512 8aa73b94719d0a4b52d8f467fb2cf7514808c2bf2573b41309cc6e10d2eee1703ab5d62ad9a576ba4190bde0d84d4abb105a3b88c88c93bb1be11cc0f6391ebf
diff --git a/dev-python/moto/moto-2.2.9.ebuild b/dev-python/moto/moto-2.2.9.ebuild
new file mode 100644
index 000000000000..2cb72d74530a
--- /dev/null
+++ b/dev-python/moto/moto-2.2.9.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-tempfile[${PYTHON_USEDEP}]' python3_{6,7})
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.9.201[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.12.201[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unpin indirect dep on ecdsa that's supposed to workaround pip bugs
+ sed -i -e '/ecdsa/s:<0.15::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}