summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-05-26 16:08:51 -0600
committerChristoph Junghans <junghans@gentoo.org>2017-05-26 16:09:25 -0600
commit76f3654bc1746267fa9d9b8a28692beba6792878 (patch)
treeb11d3d4dd8a754ee224ffa9ef19ff3828f473203
parentnet-libs/webkit-gtk: bump to 2.16.3; includes 3 security bug fixes (diff)
downloadgentoo-76f3654b.tar.gz
gentoo-76f3654b.tar.bz2
gentoo-76f3654b.zip
sys-cluster/legion: version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--sys-cluster/legion/Manifest1
-rw-r--r--sys-cluster/legion/legion-17.05.0.ebuild39
-rw-r--r--sys-cluster/legion/legion-9999.ebuild39
3 files changed, 79 insertions, 0 deletions
diff --git a/sys-cluster/legion/Manifest b/sys-cluster/legion/Manifest
index dc3c573b0db9..82c34710b9dd 100644
--- a/sys-cluster/legion/Manifest
+++ b/sys-cluster/legion/Manifest
@@ -1,3 +1,4 @@
DIST legion-16.08.0.tar.gz 2501054 SHA256 c2a344e54124172b49d97e0e0033021e9ed3d9ddb4158b0620430c5597f6ccba SHA512 8847fa8c0c7683812dd6ffb038a4d6d3427fdfde62ec917ab32e9a15cd7320321cab2b106479589aa2451cabd98cd0b1dc88b4ff668f991bb4c95f383de785a5 WHIRLPOOL 355f54164fca71c49891869644c841814600c09253bc807297bc79391f13f05fbe93029f29918167cd79a745928b0d991bc671ccd841320a32ce67941f34705c
DIST legion-16.10.0.tar.gz 2474656 SHA256 92190ae5ff0a1f6356890446e026479ed715230d4761a40d4834af256a722099 SHA512 cfe610fef047def835f95adcc4ae52d7844a4a89a5bdebb2ec40b0e63a66aba9d180bd78e559762b1ac18f84c1ca1142c3e73238dbe4c516672a8843335442a5 WHIRLPOOL 3a0e083b9d8d5c5071f1914e7cc3fda0c7c5bc2f4d187506aee9d3c1def8a046ec7732f2ce105bc3ee93075f35fc2ee7952020e2806e7f43be962018147111fb
DIST legion-17.02.0.tar.gz 2690415 SHA256 c5413fe8990c33a087c9a567671756c8267e050f5285f75ee33b84911b00c355 SHA512 0c6ee53953ec2e5072d39b1c1260a1783393feaf7064f381bb1733cf9cdb1be8fd521a35e0a452ebc9e9509d117fdc6f3e472cdb6c633ba00c987c880a33bc2d WHIRLPOOL 97bb2da8d362414d6e3c65ba2b50bf4e57041e337f6492efb27f5796c3afe0225c6324532e7413e5f9987c8395b05751d6fc0ca7b7983c21b96ef7679fdc57dc
+DIST legion-17.05.0.tar.gz 2783482 SHA256 b5f54454b28d3b61dde03711dadc2b969cf5c6412b9c1887893c5af521eba79a SHA512 51532f043eea1467a2b8ff17004f224c763f411eb5940d0a4dc5d8eb6503d758964aba26eb4977c68264c7344fcf269682a428e86a2c1a756f91cc9c50d04677 WHIRLPOOL c178ad310ef79997f4716dc7380892c814a11eadb39cbb88f1dab46df73b7fc6396262ea3a7db330847bd25b217b5f50dc5ea3c9b3e86932e3e3693e5a9eb5cb
diff --git a/sys-cluster/legion/legion-17.05.0.ebuild b/sys-cluster/legion/legion-17.05.0.ebuild
new file mode 100644
index 000000000000..443814e2abdd
--- /dev/null
+++ b/sys-cluster/legion/legion-17.05.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+if [[ $PV = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gasnet +hwloc"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
new file mode 100644
index 000000000000..443814e2abdd
--- /dev/null
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+if [[ $PV = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gasnet +hwloc"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake-utils_src_configure
+}