summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-12 00:40:26 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-12 00:43:23 -0400
commit77142d37c82bdedb492cd06aa4df2f804ab9f739 (patch)
tree928aff0cfbdac243cacce2aa3c8fc34573814363
parentdev-python/pyjwt: pytest-runner is only needed for testing in 1.5.2 (diff)
downloadgentoo-77142d37.tar.gz
gentoo-77142d37.tar.bz2
gentoo-77142d37.zip
dev-python/PyGithub: version bump to 1.35
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.35.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index eec611232da1..987d2957f0ef 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1 +1,2 @@
DIST PyGithub-1.28.tar.gz 2662625 SHA256 44feab87eefcdf311fe4ad9c356c279b56ba0fc4dd90baeaec1a52e9875cad76 SHA512 e1d9f6f473d757074220f4ec6a96f0e0a6de89af6436b8f0ab30ed22eb24b0955f0b64e6b25eae36bfe19bce580677552aedc82a7749520c5b1baac03428db7d WHIRLPOOL 6a17617816b90120b358b0181ea5743f5380367cc4b725452bf281d2f313d2bac67edff0e50178afff2a87f312befdc1809ee7494d51299d02d694f8b2ded110
+DIST PyGithub-1.35.tar.gz 2677633 SHA256 cbcddf4584c264d7b09f4e308d13f9729fa065d963adc0d3eebf0f51e0ec9908 SHA512 d852f459e5514310ac7bbb3cd9742a7269f9ea5c3e0fdfb0f385616fa31d35b72b19f63b650c60241c5e2f29860ddc35caa907a623c661bc77a29dfe4da3613b WHIRLPOOL 53acbcb05437f59a616b4450a46ee35cf66a474a852008317751769f1979de81e949fe0d2f8fbe27e7c038fdb05b2871b753c4945e883c7a101fc7500dea2a07
diff --git a/dev-python/PyGithub/PyGithub-1.35.ebuild b/dev-python/PyGithub/PyGithub-1.35.ebuild
new file mode 100644
index 000000000000..f7c3a670c22c
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.35.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="https://github.com/PyGithub/PyGithub/"
+# Use github since pypi is missing test data
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pyjwt[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}