summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasilyLebedev <vasily.lebedev@ul.ie>2020-08-29 16:58:17 +0000
committerSam James <sam@gentoo.org>2020-09-04 21:11:01 +0000
commit7724cf2bf504167b89f8522a7240e03ab3061aac (patch)
treebdf16ec449ecf5759faee641bb0a07d334a2b13b
parentdev-python/pyqt-distutils: cleanup old 0.3.0 (diff)
downloadgentoo-7724cf2bf504167b89f8522a7240e03ab3061aac.tar.gz
gentoo-7724cf2bf504167b89f8522a7240e03ab3061aac.tar.bz2
gentoo-7724cf2bf504167b89f8522a7240e03ab3061aac.zip
dev-python/pyqt-distutils: version bump to 0.7.3
Works with Python 3.{6..9}. Bug: https://bugs.gentoo.org/719428 Closes: https://bugs.gentoo.org/719428 Closes: https://github.com/gentoo/gentoo/pull/17317 Signed-off-by: Vasily A. Lebedev <lebedev.vasya@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pyqt-distutils/Manifest2
-rw-r--r--dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild27
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-python/pyqt-distutils/Manifest b/dev-python/pyqt-distutils/Manifest
index 6c49ef636120..debb05053814 100644
--- a/dev-python/pyqt-distutils/Manifest
+++ b/dev-python/pyqt-distutils/Manifest
@@ -1 +1 @@
-DIST pyqt-distutils-0.3.0.tar.gz 4659 BLAKE2B 2897696881c6ee18558eb24a923b6675588bd38456fc4e9aff6b1780e7c2c31576c4a7427104c0b15238bed1ad52e2f13ab316441adb06fc0ffd9cbe5052ef30 SHA512 052a1fa0e687ac9aba5fc9623c72f8fff9a25f6d19083668e900ad1ff98bdd99c66c0ac45ba5f5f0c09b76a97370ebf4a4fef9fbd266bc0312bb05567c4ae577
+DIST pyqt-distutils-0.7.3.gh.tar.gz 16628 BLAKE2B 0d9d7f951890c00efd95bf3caef8c8964d02f3097840f84006a8d9523c0ad9b78dbb5f46c4d752945074ba971c92e81e81be0345b7a8c807932e7157ecd00e03 SHA512 450569be205aa0de792c3f2d8c43e26eb6fed1088b241291347ae14d2343b61517bd7547f741bd62bb9e1bfb92077d1ae5c64b871c39d59a67ca82172ac1c598
diff --git a/dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild
new file mode 100644
index 000000000000..7679856ab818
--- /dev/null
+++ b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="distutils extension to work with PyQt applications and UI files"
+HOMEPAGE="https://github.com/ColinDuquesnoy/pyqt_distutils"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/ColinDuquesnoy/pyqt_distutils/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest