summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-05 18:20:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-06 00:42:06 +0200
commit777b3dfa6443cdbe584b353b51596b54563e6ff4 (patch)
treede623fd8f1e7cd351bffcf06de10e709ae04357f
parentsci-libs/dlib: Drop 19.4, 19.7 and 19.16 (r0) (diff)
downloadgentoo-777b3dfa6443cdbe584b353b51596b54563e6ff4.tar.gz
gentoo-777b3dfa6443cdbe584b353b51596b54563e6ff4.tar.bz2
gentoo-777b3dfa6443cdbe584b353b51596b54563e6ff4.zip
dev-python/pycairo: fix test failure
See also: https://bugs.python.org/issue40246 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/pycairo/files/pycairo-1.19.1-py39.patch26
-rw-r--r--dev-python/pycairo/pycairo-1.18.2.ebuild2
-rw-r--r--dev-python/pycairo/pycairo-1.19.1.ebuild2
3 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pycairo/files/pycairo-1.19.1-py39.patch b/dev-python/pycairo/files/pycairo-1.19.1-py39.patch
new file mode 100644
index 000000000000..97b20227ce8b
--- /dev/null
+++ b/dev-python/pycairo/files/pycairo-1.19.1-py39.patch
@@ -0,0 +1,26 @@
+From 3ecf0a4060d6de3b92a77a393ece663455cf6add Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Sun, 10 May 2020 11:22:40 +0200
+Subject: [PATCH] tests: Fix syntax issue with Python 3.9
+
+https://bugs.python.org/issue40246
+
+I haven't actually tested with 3.9 yet, so this is just what I found
+with grep.
+---
+ tests/test_enums.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_enums.py b/tests/test_enums.py
+index 4bc2e3d..02756d0 100644
+--- a/tests/test_enums.py
++++ b/tests/test_enums.py
+@@ -79,7 +79,7 @@ def get_prefix(t):
+ # special case..
+ if name == "PathDataType":
+ name = "Path"
+- return"_".join([s.upper() for s in re.findall('[A-Z][^A-Z]*', name)])
++ return "_".join([s.upper() for s in re.findall('[A-Z][^A-Z]*', name)])
+
+ for t in types_:
+ for name in dir(t):
diff --git a/dev-python/pycairo/pycairo-1.18.2.ebuild b/dev-python/pycairo/pycairo-1.18.2.ebuild
index 7ee4d6f32165..b8e47a44e65b 100644
--- a/dev-python/pycairo/pycairo-1.18.2.ebuild
+++ b/dev-python/pycairo/pycairo-1.18.2.ebuild
@@ -28,6 +28,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-1.19.1-py39.patch" )
+
distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme
distutils_enable_tests setup.py
diff --git a/dev-python/pycairo/pycairo-1.19.1.ebuild b/dev-python/pycairo/pycairo-1.19.1.ebuild
index 01000a3ce9a2..b05ecffc14d0 100644
--- a/dev-python/pycairo/pycairo-1.19.1.ebuild
+++ b/dev-python/pycairo/pycairo-1.19.1.ebuild
@@ -28,6 +28,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${P}-py39.patch" )
+
distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme
distutils_enable_tests setup.py