summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.2019@r123.de>2023-12-25 22:11:46 +0100
committerViorel Munteanu <ceamac@gentoo.org>2023-12-26 08:03:15 +0200
commit77827ebe70f0e5b7e753fa7d935ae142a7ec24c7 (patch)
treee9e66e76df2555ffb9951dacb7ded5bce549934b
parentnet-dialup/lrzsz: drop 0.12.20-r5 (diff)
downloadgentoo-77827ebe70f0e5b7e753fa7d935ae142a7ec24c7.tar.gz
gentoo-77827ebe70f0e5b7e753fa7d935ae142a7ec24c7.tar.bz2
gentoo-77827ebe70f0e5b7e753fa7d935ae142a7ec24c7.zip
net-im/signal-desktop-bin: add new version 6.42.1
Signed-off-by: Robert Siebeck <gentoo.2019@r123.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--net-im/signal-desktop-bin/Manifest1
-rw-r--r--net-im/signal-desktop-bin/signal-desktop-bin-6.42.1.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/net-im/signal-desktop-bin/Manifest b/net-im/signal-desktop-bin/Manifest
index b1bc40dc1c29..97e0419c6261 100644
--- a/net-im/signal-desktop-bin/Manifest
+++ b/net-im/signal-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST signal-desktop_6.41.0_amd64.deb 112060160 BLAKE2B b3e342a6c768b05373e805ff0b0ea4045141a7afc35c97d6c7fe406938e7506704cabac754a21a3bf87dfc359d56b7af7da4f50cc3e49bad1ad23e7bd6f43246 SHA512 02006eabdfce87d6eff64b56e9c2997a0b0e67e754be5311edf79e543e756594423da4edb7df8760f58b3fbeee973c5477ec68ba6b92c970571387b975df7d8d
+DIST signal-desktop_6.42.1_amd64.deb 115885024 BLAKE2B 8dee29d86e98b5a8ea6a152e299ee641a9d79e86465132b652b18ac4ee96d4dda764498bc749f3e970d2ffe0dea0415e38127d1ce07566b8bfc4de23e70fb95a SHA512 c1570e11ae0c4b795330cdc9276145ed05be5c4446980a12f4a309568cc0977fb3033f5ce741441e7b3d9d34a0b5d8d759d2cd9da62df95b85162fb2c4c9c028
diff --git a/net-im/signal-desktop-bin/signal-desktop-bin-6.42.1.ebuild b/net-im/signal-desktop-bin/signal-desktop-bin-6.42.1.ebuild
new file mode 100644
index 000000000000..0e583402923d
--- /dev/null
+++ b/net-im/signal-desktop-bin/signal-desktop-bin-6.42.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/-bin/}"
+
+inherit pax-utils unpacker xdg
+
+DESCRIPTION="Allows you to send and receive messages of Signal Messenger on your computer"
+HOMEPAGE="https://signal.org/
+ https://github.com/signalapp/Signal-Desktop"
+SRC_URI="https://updates.signal.org/desktop/apt/pool/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb"
+S="${WORKDIR}"
+
+LICENSE="GPL-3 MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 ISC openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* amd64"
+IUSE="+sound"
+RESTRICT="splitdebug"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa[X(+)]
+ net-print/cups
+ sys-apps/dbus[X]
+ x11-libs/cairo
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/pango
+ sound? (
+ || (
+ media-libs/libpulse
+ media-sound/apulse
+ )
+ )
+"
+
+QA_PREBUILT="
+ opt/Signal/chrome_crashpad_handler
+ opt/Signal/chrome-sandbox
+ opt/Signal/libEGL.so
+ opt/Signal/libGLESv2.so
+ opt/Signal/libffmpeg.so
+ opt/Signal/libvk_swiftshader.so
+ opt/Signal/libvulkan.so.1
+ opt/Signal/resources/app.asar.unpacked/node_modules/*
+ opt/Signal/signal-desktop
+ opt/Signal/swiftshader/libEGL.so
+ opt/Signal/swiftshader/libGLESv2.so"
+
+src_prepare() {
+ default
+ sed -e 's| --no-sandbox||g' \
+ -i usr/share/applications/signal-desktop.desktop || die
+ unpack usr/share/doc/signal-desktop/changelog.gz
+}
+
+src_install() {
+ insinto /
+ dodoc changelog
+ doins -r opt
+ insinto /usr/share
+
+ if has_version media-sound/apulse[-sdk] && ! has_version media-sound/pulseaudio; then
+ sed -i 's/Exec=/Exec=apulse /g' usr/share/applications/signal-desktop.desktop || die
+ fi
+
+ doins -r usr/share/applications
+ doins -r usr/share/icons
+ fperms +x /opt/Signal/signal-desktop /opt/Signal/chrome-sandbox
+ fperms u+s /opt/Signal/chrome-sandbox
+ pax-mark m opt/Signal/signal-desktop opt/Signal/chrome-sandbox
+
+ dosym -r /opt/Signal/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "For using the tray icon on compatible desktop environments, start Signal with"
+ elog " '--start-in-tray' or '--use-tray-icon'."
+}