summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 14:14:01 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 14:56:18 +0200
commit77a6c6ef8feaaebd7dfd2ac00b638e1c963fb93b (patch)
treec7fe75b5f7f7d5060bd60befe28feee96688f73b
parentdev-libs/spdlog: add glibc-2.34 test (catch) patch (diff)
downloadgentoo-77a6c6ef8feaaebd7dfd2ac00b638e1c963fb93b.tar.gz
gentoo-77a6c6ef8feaaebd7dfd2ac00b638e1c963fb93b.tar.bz2
gentoo-77a6c6ef8feaaebd7dfd2ac00b638e1c963fb93b.zip
dev-python/ipykernel: add version 6.4.2, re-enable python3.10
debugpy and pydevd now have python3.10 so we can add it back here as well Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-6.4.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index e9c2c4ae13c5..53b94de6b003 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,2 +1,3 @@
DIST ipykernel-5.5.4.tar.gz 112728 BLAKE2B 489e12d0cbde2f80f2c921f026c7b84554b1fef481164e07f89b063127b01d106fc6b19f830ac321d79285fb9df065352dbc0c2a997b3629a64e766d2e50f347 SHA512 96728321fe71d528435415eda917c623269af734598a78168144d983aa64db4f9ced981fa67c83263da1ed878831669d821b84a769a08a271adafacfcbb75bf9
DIST ipykernel-6.2.0.tar.gz 110042 BLAKE2B e1e9f140d434142339c36cdf72c9c4224143aeac8ee5938488fefaf0c15b33ddb6a4e4f49e4096431c89ba6bdcf6321f73e61927186d42518cd73e6016a017ed SHA512 7f3203b072cf7a4ca71e56df0c5621f6ac44440ace2ba855b7354971d04e872621650a0351f9d1ace50ea63459290835306e71fb91d414355810fa79968ddf56
+DIST ipykernel-6.4.2.tar.gz 121253 BLAKE2B 26f8f94df823dd7a4ac41cac574e70ae98eed64f88bbcd8ce600ce6dfe1c43c224d65b5d0f9586ad05829692142e37fbb685a5d577047791831f6138b8309556 SHA512 56f0a15a1f06628e8f74749e4bad4a65dcc78ba7ff45e4fa5802d232e427e4ec152a6b6697302488d2e05d6b0cfa0cbc106ea2a593ab43de9d9defa9c169d5a6
diff --git a/dev-python/ipykernel/ipykernel-6.4.2.ebuild b/dev-python/ipykernel/ipykernel-6.4.2.ebuild
new file mode 100644
index 000000000000..de2e7bc889bb
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-6.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="https://github.com/ipython/ipykernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/debugpy-1.0.0[${PYTHON_USEDEP}]
+ <dev-python/debugpy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
+ <dev-python/ipython-8.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1.0[${PYTHON_USEDEP}]
+ <dev-python/traitlets-6.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter_client-8.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2[${PYTHON_USEDEP}]
+ <www-servers/tornado-7.0[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-inline-0.1.0[${PYTHON_USEDEP}]
+ <dev-python/matplotlib-inline-0.2.0[${PYTHON_USEDEP}]
+"
+# RDEPEND seems specifically needed in BDEPEND, at least jupyter
+# bug #816486
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
+ dev-python/ipyparallel[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:^TIMEOUT = .*:TIMEOUT = 120:' ipykernel/tests/*.py || die
+ distutils-r1_src_prepare
+}