summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-01-28 13:29:59 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-01-28 13:30:33 +0300
commit77ac2746662fcb33b9fd9f1dbe8a2b3c4d103316 (patch)
tree3e032c8c97d5f500e7b01822ee28966baee8b538
parentsys-fs/mdadm: Removed old. (diff)
downloadgentoo-77ac2746662fcb33b9fd9f1dbe8a2b3c4d103316.tar.gz
gentoo-77ac2746662fcb33b9fd9f1dbe8a2b3c4d103316.tar.bz2
gentoo-77ac2746662fcb33b9fd9f1dbe8a2b3c4d103316.zip
media-gfx/cropgui: version bump
Gentoo-Bug: 569654 Package-Manager: portage-2.2.26
-rw-r--r--media-gfx/cropgui/Manifest1
-rw-r--r--media-gfx/cropgui/cropgui-0.2.ebuild52
-rw-r--r--media-gfx/cropgui/cropgui-9999.ebuild50
-rw-r--r--media-gfx/cropgui/files/cropgui-0.2-PIL.patch26
4 files changed, 129 insertions, 0 deletions
diff --git a/media-gfx/cropgui/Manifest b/media-gfx/cropgui/Manifest
index 168914950916..5ec16d3d5797 100644
--- a/media-gfx/cropgui/Manifest
+++ b/media-gfx/cropgui/Manifest
@@ -1 +1,2 @@
+DIST cropgui-0.2.tar.gz 842734 SHA256 9b0fcbc7a8f656979ad8ffcd09b08cec9f8ad20cd617402bae0b64526b5302fc SHA512 d6a9feea8c5de57455d0f7247465108d5a931f773f4df0c91629400bcc2c958c76559a84b6cde45709bcc8936ff7f5e2b3553897a14fbec14a9f032065ce83ba WHIRLPOOL 55e54c3adbf8992acb78c27f159874797cb4d54538b5c33b5350d0781ad1204d72e8db8c3d734922fe2893ea5d57b5a16ee2f7b8dad4db71f469462ecadfd1b1
DIST cropgui_0.1.1.tar.gz 13142 SHA256 d2bab11c2bafdbcbe9c8cac7827a7e25b909b2962cef29e1ce7181ccb2834a75 SHA512 abfe8dfd46a316e970b0355f6b05e2d2a4a54243e201dfc8434ee09f31c8715471dd1f00bd0c6cda646406e6398e5b43da3269bf74d1f2d9d436d5931d2b968f WHIRLPOOL 1e4f9fca887d2d988c6d944f85cae6125472ea08118e84b5601123e2af603b16d49ed54385f9552f1cd819f447b2ceace742ee4fd1e95f5d0461f4c173a1ef7e
diff --git a/media-gfx/cropgui/cropgui-0.2.ebuild b/media-gfx/cropgui/cropgui-0.2.ebuild
new file mode 100644
index 000000000000..912767d9ac15
--- /dev/null
+++ b/media-gfx/cropgui/cropgui-0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1
+
+DESCRIPTION="GUI for lossless cropping of jpeg images"
+HOMEPAGE="http://emergent.unpythonic.net/01248401946"
+SRC_URI="https://github.com/jepler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ sed -i -e '/Encoding/d' \
+ -e '/Version/d' \
+ -e '/MimeType/s/$/&;/' \
+ -e '/Categories/s/Application;//' \
+ cropgui.desktop || die 'sed on cropgui.desktop failed'
+ # bug 471530
+ eapply "${FILESDIR}/${P}-PIL.patch"
+
+ eapply_user
+}
+
+install_cropgui_wrapper() {
+ python_domodule cropgtk.py cropgui_common.py filechooser.py cropgui.glade
+ make_wrapper "${PN}.tmp" "${PYTHON} $(python_get_sitedir)/${PN}/cropgtk.py"
+ python_newexe "${ED%/}/usr/bin/${PN}.tmp" "${PN}"
+ rm "${ED%/}/usr/bin/${PN}.tmp" || die
+}
+
+src_install() {
+ local python_moduleroot="${PN}"
+ python_foreach_impl install_cropgui_wrapper
+
+ domenu "${PN}.desktop"
+ doicon "${PN}.png"
+}
diff --git a/media-gfx/cropgui/cropgui-9999.ebuild b/media-gfx/cropgui/cropgui-9999.ebuild
new file mode 100644
index 000000000000..ac8de05757e9
--- /dev/null
+++ b/media-gfx/cropgui/cropgui-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/jepler/cropgui.git"
+PYTHON_COMPAT=( python2_7 )
+inherit eutils git-r3 python-r1
+
+DESCRIPTION="GUI for lossless cropping of jpeg images"
+HOMEPAGE="http://emergent.unpythonic.net/01248401946"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ sed -i -e '/Encoding/d' \
+ -e '/Version/d' \
+ -e '/MimeType/s/$/&;/' \
+ -e '/Categories/s/Application;//' \
+ cropgui.desktop || die 'sed on cropgui.desktop failed'
+
+ eapply_user
+}
+
+install_cropgui_wrapper() {
+ python_domodule cropgtk.py cropgui_common.py filechooser.py cropgui.glade
+ make_wrapper "${PN}.tmp" "${PYTHON} $(python_get_sitedir)/${PN}/cropgtk.py"
+ python_newexe "${ED%/}/usr/bin/${PN}.tmp" "${PN}"
+ rm "${ED%/}/usr/bin/${PN}.tmp" || die
+}
+
+src_install() {
+ local python_moduleroot="${PN}"
+ python_foreach_impl install_cropgui_wrapper
+
+ domenu "${PN}.desktop"
+ doicon "${PN}.png"
+}
diff --git a/media-gfx/cropgui/files/cropgui-0.2-PIL.patch b/media-gfx/cropgui/files/cropgui-0.2-PIL.patch
new file mode 100644
index 000000000000..3c1e91847f8e
--- /dev/null
+++ b/media-gfx/cropgui/files/cropgui-0.2-PIL.patch
@@ -0,0 +1,26 @@
+--- cropgui.orig/cropgui_common.py 2016-01-28 12:54:47.424636620 +0300
++++ cropgui/cropgui_common.py 2016-01-28 12:55:15.176635735 +0300
+@@ -13,9 +13,9 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+-import Image
+-import ImageFilter
+-import ImageDraw
++from PIL import Image
++from PIL import ImageFilter
++from PIL import ImageDraw
+ import subprocess
+ import threading
+ import Queue
+--- cropgui.orig/filechooser.py 2016-01-28 12:55:26.505635374 +0300
++++ cropgui/filechooser.py 2016-01-28 12:55:32.649635178 +0300
+@@ -8,7 +8,7 @@
+ import gobject
+
+ import os
+-import Image
++from PIL import Image
+ import cropgui_common
+
+ def apply_rotation(rotation, image):