summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-28 06:54:22 +0100
committerSam James <sam@gentoo.org>2023-04-28 07:04:12 +0100
commit77b3718f4d06bb41371886ad25b19bdd848b45df (patch)
treefa34ff4f0ee822ea64828aff67e051357db6be8e
parentdev-libs/libtar: fix configure w/ clang 16 (diff)
downloadgentoo-77b3718f4d06bb41371886ad25b19bdd848b45df.tar.gz
gentoo-77b3718f4d06bb41371886ad25b19bdd848b45df.tar.bz2
gentoo-77b3718f4d06bb41371886ad25b19bdd848b45df.zip
gnome-extra/libgsf: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/898818 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--gnome-extra/libgsf/files/1.14.50-configure-clang16.patch23
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.50-r1.ebuild48
2 files changed, 71 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/files/1.14.50-configure-clang16.patch b/gnome-extra/libgsf/files/1.14.50-configure-clang16.patch
new file mode 100644
index 000000000000..c28811401e82
--- /dev/null
+++ b/gnome-extra/libgsf/files/1.14.50-configure-clang16.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/898818
+https://gitlab.gnome.org/GNOME/libgsf/-/merge_requests/13
+
+From 167d7f96c81683392933ddb8c427e5d7c8ce284d Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 27 Apr 2023 20:34:34 +0200
+Subject: [PATCH] configure.ac: Avoid implicit int in libbz2 probe
+
+Otherwise, this probe will always fail with future compilers,
+which are likely not to support implict ints by default.
+--- a/configure.ac
++++ b/configure.ac
+@@ -427,7 +427,7 @@ if test "x$test_bz2" = xtrue ; then
+ #undef VERSION
+ #undef HAVE_STDLIB_H
+ #include <bzlib.h>
+- main ()
++ int main (void)
+ {
+ return BZ2_bzDecompressInit (NULL, 0, 0);
+ }
+--
+GitLab
diff --git a/gnome-extra/libgsf/libgsf-1.14.50-r1.ebuild b/gnome-extra/libgsf/libgsf-1.14.50-r1.ebuild
new file mode 100644
index 000000000000..1520f5d07364
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.50-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GNOME2_EAUTORECONF=yes
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgsf"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ dev-libs/gobject-introspection-common
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ test? ( dev-perl/XML-Parser )
+"
+
+PATCHES=(
+ "${FILESDIR}"/1.14.49-skip-valgrind-tests.patch
+ "${FILESDIR}"/1.14.50-configure-clang16.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}