summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-27 23:01:01 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-28 13:16:21 +0200
commit77c92e3122fd80aa9b6f817f62e4c3824c7b0402 (patch)
treed56f7efd2fd2abc8efe61916825bf1c86684df2f
parentapp-benchmarks/bootchart2: bump to 0.14.9 (diff)
downloadgentoo-77c92e31.tar.gz
gentoo-77c92e31.tar.bz2
gentoo-77c92e31.zip
dev-python/ldap3: add 2.9.1, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/ldap3/Manifest1
-rw-r--r--dev-python/ldap3/ldap3-2.9.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ldap3/Manifest b/dev-python/ldap3/Manifest
index fa7b29804bbf..b169435b6844 100644
--- a/dev-python/ldap3/Manifest
+++ b/dev-python/ldap3/Manifest
@@ -1 +1,2 @@
DIST ldap3-2.8.1.tar.gz 961648 BLAKE2B d6cbc52512efbe4f6fe5e7d19ee2ce1af3e03a8d6d08d2235eeff0f00c61fd12583c4b9fb452206ba161961c3438d109fa106a50a0edc858c24f5cd6261b2561 SHA512 f37e76e1008c990290285a757def6fe70e227393fbbdf84eb1130d5fdfd17db724c544848cc424ca7831f8cc9e8d25407fc139981ebd10818064f588adbafebf
+DIST ldap3-2.9.1.tar.gz 974013 BLAKE2B a75219403e68705b10c06e692f4f188575a4ae38c86f15ceb6d2c674e74ac44ce0f53e3ec6bf66e8413007589293e2db95497de7b0317066b36105940beb11bf SHA512 bf07ebca9a53a8c225bc3106d3bd45eb26557c6e5a3d6d45a7f8c149d938ad43825eed0d406a57b93e2e675ed7aa262828f022ab82eb683f0e3029e3ad823106
diff --git a/dev-python/ldap3/ldap3-2.9.1.ebuild b/dev-python/ldap3/ldap3-2.9.1.ebuild
new file mode 100644
index 000000000000..9258ccc46214
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.9.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="
+ https://github.com/cannatag/ldap3/
+ https://pypi.org/project/ldap3/"
+SRC_URI="https://github.com/cannatag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# tests require a ldap server and extra configuration
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]"