summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-02-25 11:04:52 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-02-25 11:04:52 +0100
commit77dc09e605081eefecb815e53d0f35d250a95a47 (patch)
tree4de74f49fb7ea9f997ee94f5186fb187b36187ca
parentdev-tcltk/tkpng: drop QA warning (diff)
downloadgentoo-77dc09e605081eefecb815e53d0f35d250a95a47.tar.gz
gentoo-77dc09e605081eefecb815e53d0f35d250a95a47.tar.bz2
gentoo-77dc09e605081eefecb815e53d0f35d250a95a47.zip
dev-tcltk/tktray: drop QA warning
Closes: https://bugs.gentoo.org/906869 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-tcltk/tktray/tktray-1.3.9-r2.ebuild6
-rw-r--r--dev-tcltk/tktray/tktray-1.3.9.ebuild33
2 files changed, 5 insertions, 34 deletions
diff --git a/dev-tcltk/tktray/tktray-1.3.9-r2.ebuild b/dev-tcltk/tktray/tktray-1.3.9-r2.ebuild
index db484aefe6cd..d378d9096777 100644
--- a/dev-tcltk/tktray/tktray-1.3.9-r2.ebuild
+++ b/dev-tcltk/tktray/tktray-1.3.9-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,6 +24,10 @@ DEPEND="
x11-libs/libXext"
RDEPEND="${DEPEND}"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ stat64 # used to test for Large File Support
+)
+
PATCHES=(
"${FILESDIR}"/1.1-ldflags.patch
)
diff --git a/dev-tcltk/tktray/tktray-1.3.9.ebuild b/dev-tcltk/tktray/tktray-1.3.9.ebuild
deleted file mode 100644
index cdfa53b8e127..000000000000
--- a/dev-tcltk/tktray/tktray-1.3.9.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="System Tray Icon Support for Tk on X11"
-HOMEPAGE="https://code.google.com/p/tktray/"
-SRC_URI="https://tktray.googlecode.com/files/${PN}${PV}.tar.gz"
-S="${WORKDIR}/${PN}${PV}"
-
-LICENSE="tcltk"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE="debug threads"
-
-# tests need actual X server with user interaction, bug #284919
-RESTRICT="test"
-
-DEPEND="
- >=dev-lang/tcl-8.4:0=
- >=dev-lang/tk-8.4:0=
- x11-libs/libXext"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/1.1-ldflags.patch )
-
-src_configure() {
- source /usr/lib/tclConfig.sh
- CPPFLAGS="-I${TCL_SRC_DIR}/generic ${CPPFLAGS}" \
- econf \
- $(use_enable debug symbols) \
- $(use_enable threads)
-}