summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-22 21:29:57 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-22 21:40:02 +0200
commit77ecba7e441dd468387111e32f24086783cff0e9 (patch)
tree272c755c7f21d4c766977df47201a7386331bb64
parentgames-arcade/orthorobot: Stop using games.eclass (diff)
downloadgentoo-77ecba7e441dd468387111e32f24086783cff0e9.tar.gz
gentoo-77ecba7e441dd468387111e32f24086783cff0e9.tar.bz2
gentoo-77ecba7e441dd468387111e32f24086783cff0e9.zip
games-arcade/orthorobot: Drop old
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-arcade/orthorobot/orthorobot-0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/games-arcade/orthorobot/orthorobot-0.ebuild b/games-arcade/orthorobot/orthorobot-0.ebuild
deleted file mode 100644
index 2a7389e1d90f..000000000000
--- a/games-arcade/orthorobot/orthorobot-0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils games
-
-DESCRIPTION="Perspective based puzzle game, where you flatten the view to move across gaps"
-HOMEPAGE="http://stabyourself.net/orthorobot/"
-SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
-
-LICENSE="CC-BY-NC-ND-3.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND=">=games-engines/love-0.8.0"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S="${WORKDIR}"
-
-src_unpack() {
- default
- #it is only one .love file (but with crappy name), so we can use asterisk
- mv *.love "${P}.zip" || die 'mv failed'
- unpack "./${P}.zip"
- rm "${P}.zip" || die 'rm failed'
-}
-
-src_prepare() {
- # fix error on quit
- sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die 'sed failed'
-
- epatch_user
-}
-
-src_install() {
- local dir="${GAMES_DATADIR}/love/${PN}"
- insinto "${dir}"
- doins -r .
- games_make_wrapper "${PN}" "love ${dir}"
- make_desktop_entry "${PN}"
- prepgamesdirs
-}
-
-pkg_postinst() {
- elog "${PN} savegames and configurations are stored in:"
- elog "~/.local/share/love/${PN}/"
-}