summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-10 21:38:26 -0700
committerMatt Turner <mattst88@gentoo.org>2022-07-10 21:57:54 -0700
commit77f75a678af220426bfdb8b8bdd7c2fe0656aa3a (patch)
tree50eee792d0a529d28a781c7d9f9884417df97a62
parentx11-apps/xwud: Version bump to 1.0.6 (diff)
downloadgentoo-77f75a678af220426bfdb8b8bdd7c2fe0656aa3a.tar.gz
gentoo-77f75a678af220426bfdb8b8bdd7c2fe0656aa3a.tar.bz2
gentoo-77f75a678af220426bfdb8b8bdd7c2fe0656aa3a.zip
x11-drivers/xf86-input-synaptics: Version bump to 1.9.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-drivers/xf86-input-synaptics/Manifest1
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-synaptics/Manifest b/x11-drivers/xf86-input-synaptics/Manifest
index b641d390de6c..5c91759e59f0 100644
--- a/x11-drivers/xf86-input-synaptics/Manifest
+++ b/x11-drivers/xf86-input-synaptics/Manifest
@@ -1 +1,2 @@
DIST xf86-input-synaptics-1.9.1.tar.bz2 503722 BLAKE2B 5ff2f792d187ff0f3fabb1ee194f4eae1397d993627ef3a74b1c838cd611fc2834c6453b57d0dc27d7a6e0bc69b717eb1cb76c87833dd1c66b1af5ac824e1d55 SHA512 978eddd456aa7361047bc3d72e5127b24b13de29b0dddb6a0acc9f9da93931baa2b22fb5d1e6be164f629a11e5d97d753b835426435396b45b1af5eb8d546c3f
+DIST xf86-input-synaptics-1.9.2.tar.xz 432380 BLAKE2B 7ba94565f454fff8ddaf33695a7a16526810bf2677ef01e9ae740fd00a95810b4d42fb0077fe93120ac72398ca18ade48c7b389ecbc37f2438beaa97a6a21db5 SHA512 6fd46505f22bba79f612fbd48dddd4818f7d874cc29caac71840744de27f1d224c68861e3a18d2a866b78178924d2f093f5260e27b221aa1fb17dbc09d66b649
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild
new file mode 100644
index 000000000000..780964e36af6
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit linux-info xorg-3
+
+DESCRIPTION="Driver for Synaptics touchpads"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=x11-base/xorg-server-1.14
+ x11-libs/libX11
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0
+ kernel_linux? ( >=dev-libs/libevdev-0.4 )"
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ x11-base/xorg-proto"
+
+check_reqs() {
+ linux-info_pkg_setup
+
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ ewarn
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn
+ fi
+}
+
+pkg_pretend() {
+ check_reqs
+}
+
+pkg_setup() {
+ check_reqs
+}