summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-02-05 20:53:43 -0700
committerTim Harder <radhermit@gentoo.org>2020-02-05 20:53:43 -0700
commit77faa6f06a4fea306c0d2ed60a04360339386e48 (patch)
tree71f3b343e71adaef7075f3d954922b26b1853415
parentgames-emulation/vbam: remove old (diff)
downloadgentoo-77faa6f0.tar.gz
gentoo-77faa6f0.tar.bz2
gentoo-77faa6f0.zip
media-sound/abcmidi: version bump to 2020.01.22
Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--media-sound/abcmidi/Manifest1
-rw-r--r--media-sound/abcmidi/abcmidi-2020.01.22.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/abcmidi/Manifest b/media-sound/abcmidi/Manifest
index 46c9cffaeedd..a97970605f4f 100644
--- a/media-sound/abcmidi/Manifest
+++ b/media-sound/abcmidi/Manifest
@@ -1,3 +1,4 @@
DIST abcMIDI-2019.05.08.zip 562151 BLAKE2B 7b7413b329a69c9f8e7cf8eec9ddb2caceb055d2256d01a2e6045008b861b8aac194bb0b2507fb96a21ddcfe228a789be63c1ad322945a7b824ff39908cefcf4 SHA512 3891e10503f319b406b175d18077c353767b1025bae73fed184988427602412ffd5bb8e1ec0513b9ebff4d0debd81535558a8157b150a4e32abad099279d4312
DIST abcMIDI-2019.06.30.zip 565169 BLAKE2B 1db656cc8f3a1b67802eb5c91a48f45df26c2dd303b58c65b2f6dd2b93a2bad263ff06f68dd56eeb94f72bdcdb00f03a11fe26e288e8ee4ac28a91c6fa513c93 SHA512 a242ab847453a73966266e3787fe51d9e1a7359d0e3aee2e9b294c02eea88b159721298625d3079b584278d84dfe95fec70a55937b02d25a9eb753eb29799b6d
DIST abcMIDI-2019.07.12.zip 565648 BLAKE2B 446dacce10d6c7aa1eb331f52fc0e82064b66bf394494c03fdade32147e456efc30ec81a82d27d212f8e32047ef1d63ad86b4c783b58c2f19c359cbc7683c0c2 SHA512 5b5948f5bf6e3560a7f3aaf98c79fda5d3b37c9c7738bc0e268adca06a72fdf1542cbd83be762ef140b54c2132be3529510c7661892b6fe8f843f258bf753f41
+DIST abcMIDI-2020.01.22.zip 569060 BLAKE2B 078ba04a614c253266a5239b5b3f133e94c1d44e2cf91c65195f85229892cd4b8d05527124741477decb8eae83d38777b27bf1135e4ad96779c0c6b68bb46747 SHA512 5897e1344ef8e88f7ae81622c18bc8144fb95e928482c8f63cd897397ce5a5d2a5f7e5a8f13a62c6f40387f875d2f3827e74dc703ccc3c9dd81cfff018efb1de
diff --git a/media-sound/abcmidi/abcmidi-2020.01.22.ebuild b/media-sound/abcmidi/abcmidi-2020.01.22.ebuild
new file mode 100644
index 000000000000..2dfe422dfb9d
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2020.01.22.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="abcMIDI-${PV}"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="https://ifdo.ca/~seymour/runabc/top.html"
+SRC_URI="https://ifdo.ca/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ local PATCHES=( "${FILESDIR}"/${PN}-2016.05.05-docs.patch )
+ default
+
+ rm configure Makefile || die
+ sed -i "s:-O2::" configure.ac || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}