summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2024-02-24 12:55:15 +0300
committerSam James <sam@gentoo.org>2024-02-24 10:03:31 +0000
commit7805d72c8427ae393bd4ab6facf7de83ae5c912c (patch)
tree0cb9b4b69413d7d6a21582899e671072776e38a5
parentdev-python/jaraco-classes: Remove old (diff)
downloadgentoo-7805d72c8427ae393bd4ab6facf7de83ae5c912c.tar.gz
gentoo-7805d72c8427ae393bd4ab6facf7de83ae5c912c.tar.bz2
gentoo-7805d72c8427ae393bd4ab6facf7de83ae5c912c.zip
media-sound/pulseaudio-daemon: Backport alsa UCM handling assertion fix to 17.0
Bug: https://bugs.gentoo.org/925345 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35512 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-17.0-pr801.patch95
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-17.0-pr802.patch64
-rw-r--r--media-sound/pulseaudio-daemon/pulseaudio-daemon-17.0-r1.ebuild386
3 files changed, 545 insertions, 0 deletions
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-17.0-pr801.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-17.0-pr801.patch
new file mode 100644
index 000000000000..6e1bd338992c
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio-17.0-pr801.patch
@@ -0,0 +1,95 @@
+From f5cacd94abcc47003bd88ad7ca1450de649ffb15 Mon Sep 17 00:00:00 2001
+From: Alper Nebi Yasak <alpernebiyasak@gmail.com>
+Date: Thu, 30 Nov 2023 20:17:22 +0300
+Subject: [PATCH] alsa-ucm: Check UCM verb before working with device status
+
+Some versions of the ALSA libraries run into a segmentation fault when
+we query a UCM device/modifier status without first setting a UCM verb.
+It's not a reasonable thing to do anyway, so check for this case and
+return an error. Also do the check in other helpers.
+
+Signed-off-by: Alper Nebi Yasak <alpernebiyasak@gmail.com>
+Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/801>
+---
+ src/modules/alsa/alsa-ucm.c | 30 ++++++++++++++++++++++++++++++
+ 1 file changed, 30 insertions(+)
+
+diff --git a/src/modules/alsa/alsa-ucm.c b/src/modules/alsa/alsa-ucm.c
+index bb9438f79..7f5136249 100644
+--- a/src/modules/alsa/alsa-ucm.c
++++ b/src/modules/alsa/alsa-ucm.c
+@@ -624,6 +624,11 @@ static long ucm_device_status(pa_alsa_ucm_config *ucm, pa_alsa_ucm_device *dev)
+ char *devstatus;
+ long status = 0;
+
++ if (!ucm->active_verb) {
++ pa_log_error("Failed to get status for UCM device %s: no UCM verb set", dev_name);
++ return -1;
++ }
++
+ devstatus = pa_sprintf_malloc("_devstatus/%s", dev_name);
+ if (snd_use_case_geti(ucm->ucm_mgr, devstatus, &status) < 0) {
+ pa_log_debug("Failed to get status for UCM device %s", dev_name);
+@@ -637,6 +642,11 @@ static long ucm_device_status(pa_alsa_ucm_config *ucm, pa_alsa_ucm_device *dev)
+ static int ucm_device_disable(pa_alsa_ucm_config *ucm, pa_alsa_ucm_device *dev) {
+ const char *dev_name = pa_proplist_gets(dev->proplist, PA_ALSA_PROP_UCM_NAME);
+
++ if (!ucm->active_verb) {
++ pa_log_error("Failed to disable UCM device %s: no UCM verb set", dev_name);
++ return -1;
++ }
++
+ /* If any of dev's conflicting devices is enabled, trying to disable
+ * dev gives an error despite the fact that it's already disabled.
+ * Check that dev is enabled to avoid this error. */
+@@ -657,6 +667,11 @@ static int ucm_device_disable(pa_alsa_ucm_config *ucm, pa_alsa_ucm_device *dev)
+ static int ucm_device_enable(pa_alsa_ucm_config *ucm, pa_alsa_ucm_device *dev) {
+ const char *dev_name = pa_proplist_gets(dev->proplist, PA_ALSA_PROP_UCM_NAME);
+
++ if (!ucm->active_verb) {
++ pa_log_error("Failed to enable UCM device %s: no UCM verb set", dev_name);
++ return -1;
++ }
++
+ /* We don't need to enable devices that are already enabled */
+ if (ucm_device_status(ucm, dev) > 0) {
+ pa_log_debug("UCM device %s is already enabled", dev_name);
+@@ -707,6 +722,11 @@ static long ucm_modifier_status(pa_alsa_ucm_config *ucm, pa_alsa_ucm_modifier *m
+ char *modstatus;
+ long status = 0;
+
++ if (!ucm->active_verb) {
++ pa_log_error("Failed to get status for UCM modifier %s: no UCM verb set", mod_name);
++ return -1;
++ }
++
+ modstatus = pa_sprintf_malloc("_modstatus/%s", mod_name);
+ if (snd_use_case_geti(ucm->ucm_mgr, modstatus, &status) < 0) {
+ pa_log_debug("Failed to get status for UCM modifier %s", mod_name);
+@@ -720,6 +740,11 @@ static long ucm_modifier_status(pa_alsa_ucm_config *ucm, pa_alsa_ucm_modifier *m
+ static int ucm_modifier_disable(pa_alsa_ucm_config *ucm, pa_alsa_ucm_modifier *mod) {
+ const char *mod_name = pa_proplist_gets(mod->proplist, PA_ALSA_PROP_UCM_NAME);
+
++ if (!ucm->active_verb) {
++ pa_log_error("Failed to disable UCM modifier %s: no UCM verb set", mod_name);
++ return -1;
++ }
++
+ /* We don't need to disable modifiers that are already disabled */
+ if (ucm_modifier_status(ucm, mod) == 0) {
+ pa_log_debug("UCM modifier %s is already disabled", mod_name);
+@@ -738,6 +763,11 @@ static int ucm_modifier_disable(pa_alsa_ucm_config *ucm, pa_alsa_ucm_modifier *m
+ static int ucm_modifier_enable(pa_alsa_ucm_config *ucm, pa_alsa_ucm_modifier *mod) {
+ const char *mod_name = pa_proplist_gets(mod->proplist, PA_ALSA_PROP_UCM_NAME);
+
++ if (!ucm->active_verb) {
++ pa_log_error("Failed to disable UCM modifier %s: no UCM verb set", mod_name);
++ return -1;
++ }
++
+ /* We don't need to enable modifiers that are already enabled */
+ if (ucm_modifier_status(ucm, mod) > 0) {
+ pa_log_debug("UCM modifier %s is already enabled", mod_name);
+--
+GitLab
+
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-17.0-pr802.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-17.0-pr802.patch
new file mode 100644
index 000000000000..3fd2adc0cff4
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio-17.0-pr802.patch
@@ -0,0 +1,64 @@
+From ed3d4f0837f670e5e5afb1afa5bcfc8ff05d3407 Mon Sep 17 00:00:00 2001
+From: Alper Nebi Yasak <alpernebiyasak@gmail.com>
+Date: Fri, 1 Dec 2023 13:28:05 +0300
+Subject: [PATCH] alsa-ucm: Replace port device UCM context assertion with an
+ error
+
+The pa_alsa_ucm_set_port() function is passed both a mapping context and
+a device port, and both of these refer to their respective UCM device.
+While switching over to having one port per mapping per UCM device, I
+expected both of these to be the same device struct, so added an assert
+checking so.
+
+This assertion gets triggered when we have multiple UCM verbs declaring
+the same UCM device name. The root cause here is that the ports' UCM
+device references are set once while creating the ports for the card, so
+they happen to be those of a specific verb and may not match those from
+a different UCM verb's profiles' mappings.
+
+Solving the root cause necessitates a larger refactor. What we actually
+assume here is that name of the UCM device is same for both the port and
+the UCM context, which ends up always true in practice. For now, replace
+the assert with a check and error.
+
+Signed-off-by: Alper Nebi Yasak <alpernebiyasak@gmail.com>
+Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/802>
+---
+ src/modules/alsa/alsa-ucm.c | 14 ++++++++++++--
+ 1 file changed, 12 insertions(+), 2 deletions(-)
+
+diff --git a/src/modules/alsa/alsa-ucm.c b/src/modules/alsa/alsa-ucm.c
+index 7f5136249..018c01739 100644
+--- a/src/modules/alsa/alsa-ucm.c
++++ b/src/modules/alsa/alsa-ucm.c
+@@ -1581,6 +1581,7 @@ int pa_alsa_ucm_set_port(pa_alsa_ucm_mapping_context *context, pa_device_port *p
+ pa_alsa_ucm_config *ucm;
+ pa_alsa_ucm_device *dev;
+ pa_alsa_ucm_port_data *data;
++ const char *dev_name, *ucm_dev_name;
+
+ pa_assert(context && context->ucm);
+
+@@ -1588,8 +1589,17 @@ int pa_alsa_ucm_set_port(pa_alsa_ucm_mapping_context *context, pa_device_port *p
+ pa_assert(ucm->ucm_mgr);
+
+ data = PA_DEVICE_PORT_DATA(port);
+- dev = context->ucm_device;
+- pa_assert(dev == data->device);
++ dev = data->device;
++ pa_assert(dev);
++
++ if (context->ucm_device) {
++ dev_name = pa_proplist_gets(dev->proplist, PA_ALSA_PROP_UCM_NAME);
++ ucm_dev_name = pa_proplist_gets(context->ucm_device->proplist, PA_ALSA_PROP_UCM_NAME);
++ if (!pa_streq(dev_name, ucm_dev_name)) {
++ pa_log_error("Failed to set port %s with wrong UCM context: %s", dev_name, ucm_dev_name);
++ return -1;
++ }
++ }
+
+ return ucm_device_enable(ucm, dev);
+ }
+--
+GitLab
+
diff --git a/media-sound/pulseaudio-daemon/pulseaudio-daemon-17.0-r1.ebuild b/media-sound/pulseaudio-daemon/pulseaudio-daemon-17.0-r1.ebuild
new file mode 100644
index 000000000000..186c05739322
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/pulseaudio-daemon-17.0-r1.ebuild
@@ -0,0 +1,386 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV/_pre*}"
+MY_P="pulseaudio-${MY_PV}"
+inherit bash-completion-r1 gnome2-utils meson optfeature systemd tmpfiles udev
+
+DESCRIPTION="Daemon component of PulseAudio (networked sound server)"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/pulseaudio/pulseaudio"
+else
+ SRC_URI="https://freedesktop.org/software/pulseaudio/releases/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+# libpulse-simple and libpulse link to libpulse-core; this is daemon's
+# library and can link to gdbm and other GPL-only libraries. In this
+# cases, we have a fully GPL-2 package. Leaving the rest of the
+# GPL-forcing USE flags for those who use them.
+LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
+
+SLOT="0"
+
+# +alsa-plugin as discussed in bug #519530
+# TODO: Find out why webrtc-aec is + prefixed - there's already the always available speexdsp-aec
+# NOTE: The current ebuild sets +X almost certainly just for the pulseaudio.desktop file
+IUSE="+alsa +alsa-plugin aptx +asyncns bluetooth dbus elogind equalizer fftw +gdbm +glib gstreamer jack ldac lirc
+ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev valgrind +webrtc-aec +X zeroconf"
+
+RESTRICT="!test? ( test )"
+
+# See "*** BLUEZ support not found (requires D-Bus)" in configure.ac
+# Basically all IUSE are either ${MULTILIB_USEDEP} for client libs or they belong under !daemon ()
+# We duplicate alsa-plugin, {native,ofono}-headset under daemon to let users deal with them at once
+REQUIRED_USE="
+ ?? ( elogind systemd )
+ alsa-plugin? ( alsa )
+ aptx? ( bluetooth )
+ bluetooth? ( dbus )
+ equalizer? ( dbus )
+ ldac? ( bluetooth )
+ ofono-headset? ( bluetooth )
+ udev? ( || ( alsa oss ) )
+ zeroconf? ( dbus )
+"
+
+# NOTE:
+# - libpcre needed in some cases, bug #472228
+# - media-libs/speexdsp is providing echo canceller implementation and used in resampler
+# TODO: libatomic_ops is only needed on some architectures and conditions, and then at runtime too
+gstreamer_deps="
+ media-libs/gst-plugins-base
+ >=media-libs/gstreamer-1.14
+"
+COMMON_DEPEND="
+ ~media-libs/libpulse-${PV}[dbus?,glib?,systemd?,valgrind?,X?]
+ >=media-libs/libpulse-16.99.1
+ dev-libs/libatomic_ops
+ >=media-libs/libsndfile-1.0.20
+ >=media-libs/speexdsp-1.2
+ alsa? ( >=media-libs/alsa-lib-1.0.24 )
+ aptx? ( ${gstreamer_deps} )
+ asyncns? ( >=net-libs/libasyncns-0.1 )
+ bluetooth? (
+ >=net-wireless/bluez-5
+ media-libs/sbc
+ )
+ dev-libs/libltdl
+ sys-kernel/linux-headers
+ >=sys-libs/libcap-2.22-r2
+ dbus? ( >=sys-apps/dbus-1.4.12 )
+ elibc_mingw? ( dev-libs/libpcre:3 )
+ elogind? ( sys-auth/elogind )
+ equalizer? (
+ sci-libs/fftw:3.0=
+ )
+ fftw? (
+ sci-libs/fftw:3.0=
+ )
+ gdbm? ( sys-libs/gdbm:= )
+ glib? ( >=dev-libs/glib-2.28.0:2 )
+ gstreamer? (
+ ${gstreamer_deps}
+ >=dev-libs/glib-2.26.0:2
+ )
+ jack? ( virtual/jack )
+ ldac? ( ${gstreamer_deps} )
+ lirc? ( app-misc/lirc )
+ ofono-headset? ( >=net-misc/ofono-1.13 )
+ orc? ( >=dev-lang/orc-0.4.15 )
+ selinux? ( sec-policy/selinux-pulseaudio )
+ sox? ( >=media-libs/soxr-0.1.1 )
+ ssl? ( dev-libs/openssl:= )
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+ udev? ( >=virtual/udev-143[hwdb(+)] )
+ valgrind? ( dev-debug/valgrind )
+ webrtc-aec? ( >=media-libs/webrtc-audio-processing-1.3:1 )
+ X? (
+ >=x11-libs/libxcb-1.6
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libX11-1.4.0
+ >=x11-libs/libXtst-1.0.99.2
+ )
+ zeroconf? ( >=net-dns/avahi-0.6.12[dbus] )
+"
+
+# pulseaudio ships a bundle xmltoman, which uses XML::Parser
+DEPEND="
+ ${COMMON_DEPEND}
+ test? ( >=dev-libs/check-0.9.10 )
+ X? ( x11-base/xorg-proto )
+"
+
+# alsa-utils dep is for the alsasound init.d script (see bug 155707); TODO: read it
+# NOTE: Only system-wide needs acct-group/audio unless elogind/systemd is not used
+RDEPEND="
+ ${COMMON_DEPEND}
+ system-wide? (
+ alsa? ( media-sound/alsa-utils )
+ acct-user/pulse
+ acct-group/audio
+ acct-group/pulse-access
+ )
+ bluetooth? (
+ ldac? ( media-plugins/gst-plugins-ldac )
+ aptx? ( media-plugins/gst-plugins-openaptx )
+ )
+ !media-video/pipewire[sound-server(+)]
+"
+unset gstreamer_deps
+
+# This is a PDEPEND to avoid a circular dep
+PDEPEND="
+ alsa? ( alsa-plugin? ( >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio] ) )
+"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/XML-Parser
+ sys-devel/gettext
+ sys-devel/m4
+ virtual/libiconv
+ virtual/libintl
+ virtual/pkgconfig
+ orc? ( >=dev-lang/orc-0.4.15 )
+ system-wide? ( dev-util/unifdef )
+"
+
+DOCS=( NEWS README )
+
+# patches merged upstream, to be removed with 17.1 or later bump
+PATCHES=(
+ "${FILESDIR}"/pulseaudio-17.0-pr801.patch
+ "${FILESDIR}"/pulseaudio-17.0-pr802.patch
+)
+
+src_prepare() {
+ default
+
+ gnome2_environment_reset
+}
+
+src_configure() {
+ local enable_bluez5_gstreamer="disabled"
+ if use aptx || use ldac ; then
+ enable_bluez5_gstreamer="enabled"
+ fi
+
+ local enable_fftw="disabled"
+ if use equalizer || use fftw ; then
+ enable_fftw="enabled"
+ fi
+
+ local emesonargs=(
+ --localstatedir="${EPREFIX}"/var
+
+ -Ddaemon=true
+ -Dclient=false
+ -Ddoxygen=false
+ -Dgcov=false
+ -Dman=true
+ # tests involve random modules, so just do them for the native # TODO: tests should run always
+ $(meson_use test tests)
+ -Ddatabase=$(usex gdbm gdbm simple) # tdb is also an option but no one cares about it
+ -Dstream-restore-clear-old-devices=true
+ -Drunning-from-build-tree=false
+
+ # Paths
+ -Dmodlibexecdir="${EPREFIX}/usr/$(get_libdir)/pulseaudio/modules" # Was $(get_libdir)/${P}
+ -Dsystemduserunitdir=$(systemd_get_userunitdir)
+ -Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
+ -Dbashcompletiondir="$(get_bashcompdir)" # Alternatively DEPEND on app-shells/bash-completion for pkg-config to provide the value
+
+ # Optional features
+ $(meson_feature alsa)
+ $(meson_feature asyncns)
+ $(meson_feature zeroconf avahi)
+ $(meson_feature bluetooth bluez5)
+ -Dbluez5-gstreamer=${enable_bluez5_gstreamer}
+ $(meson_use bluetooth bluez5-native-headset)
+ $(meson_use ofono-headset bluez5-ofono-headset)
+ -Dconsolekit=disabled
+ $(meson_feature dbus)
+ $(meson_feature elogind)
+ -Dfftw=${enable_fftw}
+ $(meson_feature glib) # WARNING: toggling this likely changes ABI
+ $(meson_feature glib gsettings) # Supposedly correct?
+ $(meson_feature gstreamer)
+ -Dgtk=disabled
+ -Dhal-compat=false
+ -Dipv6=true
+ $(meson_feature jack)
+ $(meson_feature lirc)
+ $(meson_feature ssl openssl)
+ $(meson_feature orc)
+ $(meson_feature oss oss-output)
+ -Dsamplerate=disabled # Matches upstream
+ $(meson_feature sox soxr)
+ -Dspeex=enabled
+ $(meson_feature systemd)
+ $(meson_feature tcpd tcpwrap)
+ $(meson_feature udev)
+ $(meson_feature valgrind)
+ $(meson_feature X x11)
+
+ # Echo cancellation
+ -Dadrian-aec=false # Not packaged?
+ $(meson_feature webrtc-aec)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # qpaeq moved to media-sound/qpaeq
+ if [[ -f "${ED}"/usr/bin/qpaeq ]]; then
+ rm "${ED}"/usr/bin/qpaeq || die
+ fi
+
+ # Upstream installs 'pactl' if client is built, with all symlinks except for
+ # 'pulseaudio', 'pacmd' and 'pasuspender' which are installed if server is built.
+ # This trips QA warning, workaround:
+ # - install missing aliases in media-libs/libpulse (client build)
+ # - remove corresponding symlinks in media-sound/pulseaudio-daemonclient (server build)
+ rm "${D}/$(get_bashcompdir)"/pulseaudio || die
+ rm "${D}/$(get_bashcompdir)"/pacmd || die
+ rm "${D}/$(get_bashcompdir)"/pasuspender || die
+
+ # Daemon configuration scripts will try to load snippets from corresponding '.d' dirs.
+ # Install these dirs to silence a warning if they are missing.
+ keepdir /etc/pulse/default.pa.d
+ keepdir /etc/pulse/system.pa.d
+
+ if use system-wide; then
+ newconfd "${FILESDIR}"/pulseaudio.conf.d pulseaudio
+
+ use_define() {
+ local define=${2:-$(echo ${1} | tr '[:lower:]' '[:upper:]')}
+
+ use "${1}" && echo "-D${define}" || echo "-U${define}"
+ }
+
+ unifdef -x 1 \
+ $(use_define zeroconf AVAHI) \
+ $(use_define alsa) \
+ $(use_define bluetooth) \
+ $(use_define udev) \
+ "${FILESDIR}"/pulseaudio.init.d-5 \
+ > "${T}"/pulseaudio \
+ || die
+
+ doinitd "${T}"/pulseaudio
+
+ systemd_dounit "${FILESDIR}"/pulseaudio.service
+
+ # We need /var/run/pulse, bug 442852
+ newtmpfiles "${FILESDIR}"/pulseaudio.tmpfiles pulseaudio.conf
+ else
+ # Prevent warnings when system-wide is not used, bug 447694
+ if use dbus; then
+ rm "${ED}"/usr/share/dbus-1/system.d/pulseaudio-system.conf || die
+ fi
+ fi
+
+ if use zeroconf; then
+ sed -i \
+ -e '/module-zeroconf-publish/s:^#::' \
+ "${ED}/etc/pulse/default.pa" \
+ || die
+ fi
+
+ # Only enable autospawning pulseaudio daemon on systems without systemd
+ if ! use systemd; then
+ insinto /etc/pulse/client.conf.d
+ newins "${FILESDIR}/enable-autospawn.conf" "enable-autospawn.conf"
+ fi
+
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+
+ use udev && udev_reload
+
+ if use system-wide; then
+ tmpfiles_process "pulseaudio.conf"
+
+ elog "You have enabled the 'system-wide' USE flag for pulseaudio."
+ elog "This mode should only be used on headless servers, embedded systems,"
+ elog "or thin clients. It will usually require manual configuration, and is"
+ elog "incompatible with many expected pulseaudio features."
+ elog "On normal desktop systems, system-wide mode is STRONGLY DISCOURAGED."
+ elog ""
+ elog "For more information, see"
+ elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/"
+ elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/SystemWide/"
+ elog " https://wiki.gentoo.org/wiki/PulseAudio#Headless_server"
+ elog ""
+ fi
+
+ if use bluetooth; then
+ elog "You have enabled bluetooth USE flag for pulseaudio. Daemon will now handle"
+ elog "bluetooth Headset (HSP HS and HSP AG) and Handsfree (HFP HF) profiles using"
+ elog "native headset backend by default. This can be selectively disabled"
+ elog "via runtime configuration arguments to module-bluetooth-discover"
+ elog "in /etc/pulse/default.pa"
+ elog "To disable HFP HF append enable_native_hfp_hf=false"
+ elog "To disable HSP HS append enable_native_hsp_hs=false"
+ elog "To disable HSP AG append headset=auto or headset=ofono"
+ elog "(note this does NOT require enabling USE ofono)"
+ elog ""
+ fi
+
+ if use ofono-headset; then
+ elog "You have enabled both native and ofono headset profiles. The runtime decision"
+ elog "which to use is done via the 'headset' argument of module-bluetooth-discover."
+ elog ""
+ fi
+
+ if use gstreamer; then
+ elog "GStreamer-based RTP implementation modile enabled."
+ elog "To use OPUS payload install media-plugins/gst-plugins-opus"
+ elog "and add enable_opus=1 argument to module-rtp-send"
+ elog ""
+ fi
+
+ if use systemd; then
+ elog "Pulseaudio autospawn by client library is no longer enabled when systemd is available."
+ elog "It's recommended to start pulseaudio via its systemd user units:"
+ elog ""
+ elog " systemctl --user enable pulseaudio.service pulseaudio.socket"
+ elog ""
+ elog "Root user can change system default configuration for all users:"
+ elog ""
+ elog " systemctl --global enable pulseaudio.service pulseaudio.socket"
+ elog ""
+ elog "If you would like to enable autospawn by client library, edit autospawn flag in /etc/pulse/client.conf like this:"
+ elog ""
+ elog " autospawn = yes"
+ elog ""
+ elog "The change from autospawn to user units will take effect after restarting."
+ elog ""
+ fi
+
+ optfeature_header "PulseAudio can be enhanced by installing the following:"
+ use equalizer && optfeature "qpaeq script for equalizer GUI" media-sound/qpaeq
+ use dbus && optfeature "restricted realtime capabilities via D-Bus" sys-auth/rtkit
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ use udev && udev_reload
+}