summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-04-21 10:17:56 +0200
committerJeroen Roovers <jer@gentoo.org>2020-04-21 10:22:52 +0200
commit7806f648b2db221066cf24c240b5b81da1251bed (patch)
tree2701c3bcd466593593b1b70fa323993afbb558f6
parentnet-misc/asterisk: fix USE=-samples. (diff)
downloadgentoo-7806f648b2db221066cf24c240b5b81da1251bed.tar.gz
gentoo-7806f648b2db221066cf24c240b5b81da1251bed.tar.bz2
gentoo-7806f648b2db221066cf24c240b5b81da1251bed.zip
net-ftp/ncftp: Update HOMEPAGE/SRC_URI/A
- Use HTTPS for HOMEPAGE and SRC_URI - Update A because why not, and also because upstream changed the source tarball considerably (again): NcFTP Change Log: ================ -3.2.6, 2016-09-23 +3.2.6, 2016-12-04 ... 58 files changed, 1538 insertions(+), 863 deletions(-) Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-ftp/ncftp/Manifest1
-rw-r--r--net-ftp/ncftp/ncftp-3.2.6-r2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-ftp/ncftp/Manifest b/net-ftp/ncftp/Manifest
index 381b7c3037e1..8cceb8f46abf 100644
--- a/net-ftp/ncftp/Manifest
+++ b/net-ftp/ncftp/Manifest
@@ -1 +1,2 @@
+DIST ncftp-3.2.6-src.tar.xz 420564 BLAKE2B ce6d8d2bf06761f884e9edfe6d0bb0230f5d515078a787c4e6faf7716b760166acdd0accf3de1e1f5f3d892c8c86348cdbbefeac6be05e6806011a3e8f4c9b02 SHA512 8e6091ce2ea1eb463edea322d1b5dde813475fd22096d67f0bfd2f5101ae09747ff25d38816d0b9b1077e6a5a256078361691f816aa2eefa38638aa523b4b382
DIST ncftp-3.2.6.tar.xz 418836 BLAKE2B f0ffa0cc26617ee4007fe8589dbbc8d122edbfc8106a8618a66eab5d9def258d2ee9c2b709e1a637b9d833513ef87b652f4ab0ff518dc9d67d90a7dd43941d3c SHA512 040db7e2ca2ee78b79d682a951fd98c1e0ee2936b64462259992d70c51241fa50ae06c66b4f40933ad0ab7122f581bbb8ba7cda764dba5f70a1f8c7d3d751199
diff --git a/net-ftp/ncftp/ncftp-3.2.6-r2.ebuild b/net-ftp/ncftp/ncftp-3.2.6-r2.ebuild
new file mode 100644
index 000000000000..30b5c3cc3f0b
--- /dev/null
+++ b/net-ftp/ncftp/ncftp-3.2.6-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An extremely configurable ftp client"
+HOMEPAGE="https://www.ncftp.com/"
+SRC_URI="
+ https://ftp.mirrorservice.org/sites/ftp.${PN}.com/${PN}/${P}-src.tar.xz
+"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
+IUSE="pch"
+
+DEPEND="
+ sys-libs/ncurses:*
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.6-fno-common.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR=autoconf_local/ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ LC_ALL="C" \
+ LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses)" \
+ econf \
+ $(use_enable pch precomp) \
+ --disable-ccdv \
+ --disable-universal
+}
+
+src_install() {
+ default
+ dodoc README.txt doc/*.txt
+ docinto html
+ dodoc doc/html/*.html
+}