summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-01-29 11:47:37 -0600
committerBen Kohler <bkohler@gentoo.org>2020-01-29 11:48:06 -0600
commit782156e886fb0d76fa2831b36ec0c7f48f6278a4 (patch)
treeebb4f51b675d2615a2a548d85f41542ad61eace4
parentnet-libs/libupnp: 1.12.0: Fix C++ compat (diff)
downloadgentoo-782156e8.tar.gz
gentoo-782156e8.tar.bz2
gentoo-782156e8.zip
net-misc/wput: bump to 0.6.2 w/ crash fix
Closes: https://bugs.gentoo.org/647848 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--net-misc/wput/Manifest1
-rw-r--r--net-misc/wput/files/wput-0.6.2-respect-destdir.patch23
-rw-r--r--net-misc/wput/files/wput-fix-crash.patch47
-rw-r--r--net-misc/wput/wput-0.6.2.ebuild36
4 files changed, 107 insertions, 0 deletions
diff --git a/net-misc/wput/Manifest b/net-misc/wput/Manifest
index 31766c93b6c5..5e669fa06ef3 100644
--- a/net-misc/wput/Manifest
+++ b/net-misc/wput/Manifest
@@ -1 +1,2 @@
DIST wput-0.6.1.tgz 312342 BLAKE2B 67053f71307e9fbb3f085e9347c7843f4bcaf951858164fa228f9cfd80898192efc344f1f9cbf65a3db286fae5b514da64ed3599627f264586c9242ac753f62b SHA512 f5eb5e343c77cec0f3370e8d73679e3c720a848a963c2cdc64e6c52f30b47d76e0de9ccde965da9af97d2e5f23f45dd894f26371f56ead498d28fadffe65fc4b
+DIST wput-0.6.2.tgz 368510 BLAKE2B bf59720e220d837354aff7d90bf06dcf54df4adf10c53ca844cb18dc6f327793ebd5dce7beecc76b43ddccfe273435a1eca918ab2272145dc8bf47293f601004 SHA512 e1d0fb8570cbda44c97215ee1a021a9867f2e91323b3d7f7df1d7fd68a1b2aba40a7f3068e5e85e8c736b1dba1fba62df375af99e3fb96cd0fd414b139c641bd
diff --git a/net-misc/wput/files/wput-0.6.2-respect-destdir.patch b/net-misc/wput/files/wput-0.6.2-respect-destdir.patch
new file mode 100644
index 000000000000..f0cbfcdebd69
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6.2-respect-destdir.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile.in b/Makefile.in
+index 6756cd2..6debea8 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -16,12 +16,12 @@ win-clean:
+
+ install: all
+ cd po && $(MAKE) $(MAKEDEFS) $@
+- mkdir -p $(bindir)
+- mkdir -p $(mandir)
+- install -m0755 wput $(bindir)
+- install -m0644 doc/wput.1.gz $(mandir)
+- ln -s $(bindir)/wput $(bindir)/wdel
+- install -m0644 doc/wdel.1.gz $(mandir)
++ install -d $(DESTDIR)/$(bindir)
++ install -d $(DESTDIR)/$(mandir)
++ install -m0755 wput $(DESTDIR)/$(bindir)
++ install -m0644 doc/wput.1 $(DESTDIR)/$(mandir)
++ ln -s wput $(DESTDIR)/$(bindir)/wdel
++ install -m0644 doc/wdel.1 $(DESTDIR)/$(mandir)
+ @echo "----------------"
+ @echo "Wput and Wdel installed. See 'wput/wdel -h' or 'man wput/wdel' for"
+ @echo "usage information."
diff --git a/net-misc/wput/files/wput-fix-crash.patch b/net-misc/wput/files/wput-fix-crash.patch
new file mode 100644
index 000000000000..2afab8e59913
--- /dev/null
+++ b/net-misc/wput/files/wput-fix-crash.patch
@@ -0,0 +1,47 @@
+diff -ur wput-0.6.2+git20130413.orig/src/progress.c wput-0.6.2+git20130413/src/progress.c
+--- wput-0.6.2+git20130413.orig/src/progress.c 2013-07-15 00:05:50.000000000 +0200
++++ wput-0.6.2+git20130413/src/progress.c 2016-10-25 16:48:05.909105000 +0200
+@@ -181,7 +181,7 @@
+ static char output[15];
+ time_t secs = time (NULL);
+ struct tm *ptm = localtime (&secs);
+- sprintf (output, "%02d:%02d:%02d", ptm->tm_hour, ptm->tm_min, ptm->tm_sec);
++ snprintf (output, sizeof(output), "%02d:%02d:%02d", ptm->tm_hour, ptm->tm_min, ptm->tm_sec);
+ return output;
+ }
+
+@@ -261,11 +261,11 @@
+ unit = 3, trate = trate / (1024 * 1024 * 1024);
+
+ if(trate < 100)
+- sprintf(buf, "%s%.2f%s", (trate < 10) ? " " : "", trate, units[sp][unit]);
++ snprintf(buf, sizeof(buf), "%s%.2f%s", (trate < 10) ? " " : "", trate, units[sp][unit]);
+ else if(trate < 1000)
+- sprintf(buf, "%.1f%s", trate, units[sp][unit]);
++ snprintf(buf, sizeof(buf), "%.1f%s", trate, units[sp][unit]);
+ else
+- sprintf(buf, " %d%s", (int) trate, units[sp][unit]);
++ snprintf(buf, sizeof(buf), " %d%s", (int) trate, units[sp][unit]);
+ return buf;
+ }
+ /* wrapper for our progress_bar */
+@@ -303,13 +303,15 @@
+ remain = (int) (WINCONV (fsession->local_fsize - transfered) * ((double) time_diff * 1000)
+ / (double) WINCONV tbytes / 1000);
+ if(remain < 60)
+- sprintf(buf, "ETA %02ds", remain);
++ snprintf(buf, sizeof(buf), "ETA %02ds", remain);
+ else if(remain < 3600)
+- sprintf(buf, "ETA %2d:%02dm", remain / 60, remain % 60);
++ snprintf(buf, sizeof(buf), "ETA %2d:%02dm", remain / 60, remain % 60);
+ else if(remain < 3600 * 24)
+- sprintf(buf, "ETA %2d:%02dh", remain / 3600, (remain % 3600) / 60);
++ snprintf(buf, sizeof(buf), "ETA %2d:%02dh", remain / 3600, (remain % 3600) / 60);
++ else if(remain < 3600 * 24 * 100)
++ snprintf(buf, sizeof(buf), "ETA %2d:%02dd", remain / (3600 * 24), (remain % (24 * 3600)) / 3600);
+ else
+- sprintf(buf, "ETA %2d:%02dd", remain / (3600 * 24), (remain % (24 * 3600)) / 3600);
++ snprintf(buf, sizeof(buf), "ETA **:** ");
+ /* NO, there won't be an eta of weeks or years! 14.4modem times are gone ;). god bless all gprs-users */
+
+ return buf;
diff --git a/net-misc/wput/wput-0.6.2.ebuild b/net-misc/wput/wput-0.6.2.ebuild
new file mode 100644
index 000000000000..c95956b3e7b1
--- /dev/null
+++ b/net-misc/wput/wput-0.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tiny program like wget, to upload files/whole directories via FTP"
+HOMEPAGE="http://wput.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug nls ssl"
+
+RDEPEND="ssl? ( net-libs/gnutls )"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.2-respect-destdir.patch"
+ "${FILESDIR}/${PN}-0.6-respectldflags.patch"
+ "${FILESDIR}/${PN}-fix-crash.patch"
+)
+
+DOCS=( ChangeLog INSTALL TODO )
+
+src_configure() {
+ local myconf="--enable-g-switch=no"
+ use debug && myconf="--enable-memdbg=yes"
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ "${myconf}"
+}