summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew White <mehw.is.me@inventati.org>2021-10-23 19:29:44 +0200
committerSam James <sam@gentoo.org>2021-10-24 03:21:41 +0000
commit784d85246bab32bfd9491dd8e281f7f9c6100395 (patch)
treee9513e9c76fd1bc44879fb9cf288c611049148f6
parentdev-perl/Sys-CpuLoad: add missing dependency (diff)
downloadgentoo-784d85246bab32bfd9491dd8e281f7f9c6100395.tar.gz
gentoo-784d85246bab32bfd9491dd8e281f7f9c6100395.tar.bz2
gentoo-784d85246bab32bfd9491dd8e281f7f9c6100395.zip
app-misc/wcd: fix docs installed into unexpected path
Install docs into /usr/share/doc/wcd-${PVR}. Closes: https://bugs.gentoo.org/802696 Package-Manager: Portage-3.0.20-r6, Repoman-3.0.3-r1 Signed-off-by: Matteo Bianco <mehw.is.me@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/22685 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/wcd/files/wcd-6.0.3-doc-path.patch14
-rw-r--r--app-misc/wcd/wcd-6.0.3-r2.ebuild47
2 files changed, 61 insertions, 0 deletions
diff --git a/app-misc/wcd/files/wcd-6.0.3-doc-path.patch b/app-misc/wcd/files/wcd-6.0.3-doc-path.patch
new file mode 100644
index 000000000000..16e850a8baac
--- /dev/null
+++ b/app-misc/wcd/files/wcd-6.0.3-doc-path.patch
@@ -0,0 +1,14 @@
+Install docs into /usr/share/doc/wcd-${PVR}.
+
+diff -Nuar a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2019-08-14 10:07:15.000000000 +0000
++++ b/src/Makefile 2021-10-23 17:10:17.000000000 +0000
+@@ -61,7 +61,7 @@
+ datarootdir = $(prefix)/share
+ datadir = $(datarootdir)
+
+-docsubdir = $(PACKAGE)-$(VERSION)
++docsubdir = $(PACKAGE)-$(PVR)
+ docdir = $(datarootdir)/doc/$(docsubdir)
+ localedir = $(datarootdir)/locale
+ sysconfdir = /etc
diff --git a/app-misc/wcd/wcd-6.0.3-r2.ebuild b/app-misc/wcd/wcd-6.0.3-r2.ebuild
new file mode 100644
index 000000000000..7c052415034d
--- /dev/null
+++ b/app-misc/wcd/wcd-6.0.3-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Wherever Change Directory"
+HOMEPAGE="http://waterlan.home.xs4all.nl/#WCD_ANCHOR"
+SRC_URI="http://waterlan.home.xs4all.nl/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls unicode"
+
+CDEPEND="
+ sys-libs/ncurses:=[unicode(+)?]
+ unicode? ( dev-libs/libunistring:= )"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ app-text/ghostscript-gpl
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ eapply -p2 "${FILESDIR}"/${PN}-6.0.2-gentoo.patch
+ eapply -p2 "${FILESDIR}"/${P}-doc-path.patch
+ eapply_user
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ local mycompile="LFS=1"
+ use nls || mycompile+=" ENABLE_NLS="
+ use unicode && mycompile+=" UCS=1 UNINORM=1"
+ emake ${mycompile}
+}
+
+src_install() {
+ local DOCS=( ../README.txt )
+ default
+ emake DESTDIR="${D}" DOTWCD=1 install-profile sysconfdir="/etc"
+}