summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-11 18:26:39 +0000
committerSam James <sam@gentoo.org>2023-12-14 05:21:54 +0000
commit786a1575c3be3d8680b2b4aec6254cbae90ab30d (patch)
tree84e63c605a2b78a82afe227dfb6fd65267ae0935
parentpython-utils-r1.eclass: Disable pytest-salt-factories by default (diff)
downloadgentoo-786a1575c3be3d8680b2b4aec6254cbae90ab30d.tar.gz
gentoo-786a1575c3be3d8680b2b4aec6254cbae90ab30d.tar.bz2
gentoo-786a1575c3be3d8680b2b4aec6254cbae90ab30d.zip
distutils-r1.eclass: workaround cython bug for Modern C
Pass -Wno-error=incompatible-pointer-types for now to avoid many dupes for the same cython bug. Bug: https://github.com/cython/cython/issues/2747 Bug: https://bugs.gentoo.org/918983 Bug: https://bugs.gentoo.org/919261 Bug: https://bugs.gentoo.org/919277 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--eclass/distutils-r1.eclass5
1 files changed, 5 insertions, 0 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 0a7b18e4a1a4..6d2640b29598 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1806,6 +1806,11 @@ distutils-r1_run_phase() {
tc-export AR CC CPP CXX
if [[ ${DISTUTILS_EXT} ]]; then
+ if [[ ${BDEPEND} == *dev-python/cython* ]] ; then
+ # Workaround for https://github.com/cython/cython/issues/2747 (bug #918983)
+ local -x CFLAGS="${CFLAGS} $(test-flags-CC -Wno-error=incompatible-pointer-types)"
+ fi
+
local -x CPPFLAGS="${CPPFLAGS} $(usex debug '-UNDEBUG' '-DNDEBUG')"
# always generate .c files from .pyx files to ensure we get latest
# bug fixes from Cython (this works only when setup.py is using