summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-07-22 21:12:29 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-07-22 21:12:29 +0900
commit786dd62624cd12bf4715989c4c33fe99372cf26e (patch)
tree1fff24546812a560920c91b1fbfbbffce05ab49b
parentsci-electronics/puff: EAPI7, improve ebuild (diff)
downloadgentoo-786dd62624cd12bf4715989c4c33fe99372cf26e.tar.gz
gentoo-786dd62624cd12bf4715989c4c33fe99372cf26e.tar.bz2
gentoo-786dd62624cd12bf4715989c4c33fe99372cf26e.zip
mail-client/sylpheed: drop old
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--mail-client/sylpheed/Manifest1
-rw-r--r--mail-client/sylpheed/metadata.xml21
-rw-r--r--mail-client/sylpheed/sylpheed-3.5.1.ebuild63
3 files changed, 11 insertions, 74 deletions
diff --git a/mail-client/sylpheed/Manifest b/mail-client/sylpheed/Manifest
index 09d501082a8a..b1df94ce354c 100644
--- a/mail-client/sylpheed/Manifest
+++ b/mail-client/sylpheed/Manifest
@@ -1,3 +1,2 @@
-DIST sylpheed-3.5.1.tar.bz2 3561816 BLAKE2B 811d433a2930d32dd6d2a5aa3010c4cfe54e514a7705624dc7ae067b3e5db1a3aa745e980c0e240b1b6515535c8ee38988aa8410ea07369f77d53bade561b462 SHA512 264aafb40eaa163405074480b2deb7eefe0d2158a107d9b26bc35d5506dcf5a52cf5712b81bd4c06b4c76e48c6e372c74473e5371bbdc80f230267f3b211c7f5
DIST sylpheed-3.6.0.tar.bz2 3568998 BLAKE2B 283ea6c956eb67332b9f1ba34cecb2be853a079d398b5165e925b9adfe33b75d5eab559b91a707b5c76d9253f35acbf4177afcbb90e86fb48b45bcd9aa517768 SHA512 84c59e327690ed7e637e9ce60e630da6cdad771ccc278e31e490ed643da55c295fb47e999ad421fc59dbbcfed990882022b96cf478bd47253692d2e86279c591
DIST sylpheed-3.7.0.tar.bz2 3612328 BLAKE2B bd8182db8a46b956e12b3da4b15d3ee8184a612e2fb216aca20fd4a022610b17416f994d36b390a5a92835915e95f08bd59bf71154a86962c9564162be891f21 SHA512 490837528bf7ba9d26994cd5fff00b6e5390a127419b9d0efd9fc25c38be1291d55c5b8daebdf5ca9d9159a51c938449e76212328f3eae40cc039db88cb5caa4
diff --git a/mail-client/sylpheed/metadata.xml b/mail-client/sylpheed/metadata.xml
index 2ab17e94c001..ee28f2975e66 100644
--- a/mail-client/sylpheed/metadata.xml
+++ b/mail-client/sylpheed/metadata.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>hattya@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>net-mail@gentoo.org</email>
- <name>Net-Mail</name>
- </maintainer>
- <use>
- <flag name="oniguruma">Use <pkg>dev-libs/oniguruma</pkg> for regular expression</flag>
- </use>
+ <maintainer type="person">
+ <email>hattya@gentoo.org</email>
+ <name>Akinori Hattori</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>net-mail@gentoo.org</email>
+ <name>Net-Mail</name>
+ </maintainer>
+ <use>
+ <flag name="oniguruma">Use <pkg>dev-libs/oniguruma</pkg> for regular expression</flag>
+ </use>
</pkgmetadata>
diff --git a/mail-client/sylpheed/sylpheed-3.5.1.ebuild b/mail-client/sylpheed/sylpheed-3.5.1.ebuild
deleted file mode 100644
index c6ea5a099822..000000000000
--- a/mail-client/sylpheed/sylpheed-3.5.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils
-
-DESCRIPTION="A lightweight email client and newsreader"
-HOMEPAGE="http://sylpheed.sraoss.jp/"
-SRC_URI="http://${PN}.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="crypt ipv6 ldap libressl nls oniguruma pda spell ssl xface"
-
-CDEPEND="x11-libs/gtk+:2
- crypt? ( app-crypt/gpgme )
- ldap? ( net-nds/openldap )
- nls? ( sys-devel/gettext )
- oniguruma? ( dev-libs/oniguruma:= )
- pda? ( app-pda/jpilot )
- spell? ( app-text/gtkspell:2 )
- ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )"
-RDEPEND="${CDEPEND}
- app-misc/mime-types
- net-misc/curl"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- xface? ( media-libs/compface )"
-
-src_configure() {
- local htmldir=/usr/share/doc/${PF}/html
- econf \
- $(use_enable crypt gpgme) \
- $(use_enable ipv6) \
- $(use_enable ldap) \
- $(use_enable oniguruma) \
- $(use_enable pda jpilot) \
- $(use_enable spell gtkspell) \
- $(use_enable ssl) \
- $(use_enable xface compface) \
- --with-plugindir=/usr/$(get_libdir)/${PN}/plugins \
- --with-manualdir=${htmldir}/manual \
- --with-faqdir=${htmldir}/faq \
- --disable-updatecheck
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog* NEWS* PLUGIN* README* TODO*
-
- doicon *.png
- domenu *.desktop
-
- cd plugin/attachment_tool
- emake DESTDIR="${D}" install-plugin
- docinto plugin/attachment_tool
- dodoc README
-}