summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-14 09:25:43 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-15 10:13:37 +0300
commit786f52cb8eef895dbd5d29d6992ca060b396de89 (patch)
treee216b1947ef337cfb850149de356df3cf0cc9c78
parentdev-python/rencode: x86 stable wrt bug #813055 (diff)
downloadgentoo-786f52cb.tar.gz
gentoo-786f52cb.tar.bz2
gentoo-786f52cb.zip
dev-python/watchgod: New NIH dep for dev-python/uvicorn
Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/watchgod/Manifest1
-rw-r--r--dev-python/watchgod/metadata.xml11
-rw-r--r--dev-python/watchgod/watchgod-0.7.ebuild29
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/watchgod/Manifest b/dev-python/watchgod/Manifest
new file mode 100644
index 000000000000..d90469d433c8
--- /dev/null
+++ b/dev-python/watchgod/Manifest
@@ -0,0 +1 @@
+DIST watchgod-0.7.gh.tar.gz 14362 BLAKE2B 0c16b7ef2a7e1d0ca2c9d27b1503a9710662364318d5021e916aabf90c8f917b0bf69559a545658f839953832edc579b0014a0736b3b155f097d1d29c2e4b4f7 SHA512 afa225b30cf796ce95861c61fbe8eb22ed72011522de53d53c41148311793db10e41b66e9eb1237c4372f142edaec992de79715c568e435ddb1695666be1cdd8
diff --git a/dev-python/watchgod/metadata.xml b/dev-python/watchgod/metadata.xml
new file mode 100644
index 000000000000..37627d68f75d
--- /dev/null
+++ b/dev-python/watchgod/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">samuelcolvin/watchgod</remote-id>
+ <remote-id type="pypi">watchgod</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/watchgod/watchgod-0.7.ebuild b/dev-python/watchgod/watchgod-0.7.ebuild
new file mode 100644
index 000000000000..66b254733fc1
--- /dev/null
+++ b/dev-python/watchgod/watchgod-0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Simple, modern file watching and code reload in Python"
+HOMEPAGE="
+ https://pypi.org/project/watchgod/
+ https://github.com/samuelcolvin/watchgod/"
+SRC_URI="
+ https://github.com/samuelcolvin/watchgod/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-toolbox[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest