summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-13 08:55:42 +0000
committerSam James <sam@gentoo.org>2021-06-13 11:07:31 +0000
commit7882e0389a47b3a625d33d9689a8415e030ecd9c (patch)
tree9bccebba2b867c1f481e50712e851c876595c0cf
parentdev-ml/graphics: add subslot operator for OCaml (diff)
downloadgentoo-7882e0389a47b3a625d33d9689a8415e030ecd9c.tar.gz
gentoo-7882e0389a47b3a625d33d9689a8415e030ecd9c.tar.bz2
gentoo-7882e0389a47b3a625d33d9689a8415e030ecd9c.zip
app-office/texstudio: drop 3.0.5-r1, 3.1.0-r1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-office/texstudio/Manifest2
-rw-r--r--app-office/texstudio/texstudio-3.0.5-r1.ebuild76
-rw-r--r--app-office/texstudio/texstudio-3.1.0-r1.ebuild76
3 files changed, 0 insertions, 154 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index 06c095eddc67..19a8b984d067 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -1,4 +1,2 @@
-DIST texstudio-3.0.5.tar.gz 83231803 BLAKE2B 739a57fa5305ad8044f8fc13903910ee743cac353aeed53b298dd3d50291c4e5b2d2b67db7785305d1f1c71ba805769a57b46374c762efd39bc1a450f1df470e SHA512 240d177ffbd64f51a8f2aa93644cae29764876ed6fdd03733da05ed97a8ec10e21c1f3aebcb05b35617083abf0442b60ffe8f0a89edb28adacaf9ebe40609a48
-DIST texstudio-3.1.0.tar.gz 83232492 BLAKE2B 6e890fb19a51d8f1fdecbf844f674579391cfea4c3e41535db1daca78d24774e085d7c3c7d2c1eae6e7c287e9ab1d465e1082a25e95b95a7b62930a416bd654d SHA512 83d758102b597eae928e68a59035a83d90a950920995dc992a4478f8eba8ccb1f038a01bd07cce2681f354cad735394b2637cb79899d8e89960bae258652b3d8
DIST texstudio-3.1.1.tar.gz 83239128 BLAKE2B 7aeedba9ec5a404d51e8854a67c2e07f4efdc03882ebe83ba4d5e99376dcac5c906b40f093129106cfbec716be6001ae6c1848f323147289a5d252c713cb25a6 SHA512 b8c843693d781052914f43215ee42c7bafd4bffe676aede966bafa08b4b74616b55a60e611878a8f0188c84d364ba27f86425adfd4e640c7d4390b0fdfcee8c7
DIST texstudio-3.1.2.tar.gz 83987451 BLAKE2B 0649a4f2a429d1d7a6134e154c338f623de23c8b05829a169599f6950b59190736a0f4c2a4dc0e57ae2c47a5eb26594639660a8b691adbb768cb013061d5c1d8 SHA512 c8ce74cca6620ba725c4e8ff66564cc4804f3b922877af5c4952a8cd5b43fdf2deb88c1515f457f75a67d7d29ca1d6307779b8304c0b78b37f585c61a12221c4
diff --git a/app-office/texstudio/texstudio-3.0.5-r1.ebuild b/app-office/texstudio/texstudio-3.0.5-r1.ebuild
deleted file mode 100644
index 375790905ee9..000000000000
--- a/app-office/texstudio/texstudio-3.0.5-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PV="${PV/_/}"
-inherit desktop qmake-utils xdg
-
-DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
-HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
-SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="video"
-
-DEPEND="
- app-text/hunspell:=
- app-text/poppler[qt5]
- >=dev-libs/quazip-0.7.3-r1:0=
- dev-qt/designer:5
- dev-qt/qtcore:5
- dev-qt/qtconcurrent:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtprintsupport:5
- dev-qt/qtscript:5
- dev-qt/qtsingleapplication[qt5(+),X]
- dev-qt/qtsvg:5
- dev-qt/qttest:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- sys-libs/zlib
- x11-libs/libX11
- x11-libs/libXext
- video? ( >=media-libs/phonon-4.11.0 )
-"
-RDEPEND="${DEPEND}
- app-text/ghostscript-gpl
- app-text/psutils
- media-libs/netpbm
- virtual/latex-base
-"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/${P}-quazip1.patch" ) # TODO: upstream
-
-src_prepare() {
- xdg_src_prepare
-
- if has_version "<dev-libs/quazip-1.0"; then
- sed -e "/PKGCONFIG/s/quazip1-qt5/quazip/" -i ${PN}.pro || die
- fi
- rm -r src/quazip || die
-
- if use video; then
- sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
- fi
-
- sed -e "/qtsingleapplication.pri/s/.*/CONFIG += qtsingleapplication/" \
- -i ${PN}.pro || die
-}
-
-src_configure() {
- eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1
-}
-
-src_install() {
- local i
- for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
- newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
- done
- emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
-}
diff --git a/app-office/texstudio/texstudio-3.1.0-r1.ebuild b/app-office/texstudio/texstudio-3.1.0-r1.ebuild
deleted file mode 100644
index 3a47094b7680..000000000000
--- a/app-office/texstudio/texstudio-3.1.0-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PV="${PV/_/}"
-inherit desktop qmake-utils xdg
-
-DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
-HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
-SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="video"
-
-DEPEND="
- app-text/hunspell:=
- app-text/poppler[qt5]
- >=dev-libs/quazip-0.7.3-r1:0=
- dev-qt/designer:5
- dev-qt/qtcore:5
- dev-qt/qtconcurrent:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtprintsupport:5
- dev-qt/qtscript:5
- dev-qt/qtsingleapplication[qt5(+),X]
- dev-qt/qtsvg:5
- dev-qt/qttest:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- sys-libs/zlib
- x11-libs/libX11
- x11-libs/libXext
- video? ( >=media-libs/phonon-4.11.0 )
-"
-RDEPEND="${DEPEND}
- app-text/ghostscript-gpl
- app-text/psutils
- media-libs/netpbm
- virtual/latex-base
-"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/${PN}-3.0.5-quazip1.patch" ) # TODO: upstream
-
-src_prepare() {
- xdg_src_prepare
-
- if has_version "<dev-libs/quazip-1.0"; then
- sed -e "/PKGCONFIG/s/quazip1-qt5/quazip/" -i ${PN}.pro || die
- fi
- rm -r src/quazip || die
-
- if use video; then
- sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
- fi
-
- sed -e "/qtsingleapplication.pri/s/.*/CONFIG += qtsingleapplication/" \
- -i ${PN}.pro || die
-}
-
-src_configure() {
- eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1
-}
-
-src_install() {
- local i
- for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
- newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
- done
- emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
-}