summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-05 17:54:21 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-05 19:00:11 -0400
commit788f969a0b47ea7ceb6cdbfec513126adb70243e (patch)
tree704b6b45ae0c5c4745c347c80d475bf585017915
parentprofiles: Mask x11-libs/libva-vdpau-driver for removal (diff)
downloadgentoo-788f969a.tar.gz
gentoo-788f969a.tar.bz2
gentoo-788f969a.zip
app-text/binfind: fix configure with upcoming clang16
eautoreconf should not be needed per-se for clang16 but custom test in configure.in missed an header, so let's regen. Closes: https://bugs.gentoo.org/870832 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-text/binfind/binfind-0.0.3.ebuild17
-rw-r--r--app-text/binfind/files/binfind-0.0.3-clang16.patch9
2 files changed, 23 insertions, 3 deletions
diff --git a/app-text/binfind/binfind-0.0.3.ebuild b/app-text/binfind/binfind-0.0.3.ebuild
index 98b9511f6370..fce82cc6b67d 100644
--- a/app-text/binfind/binfind-0.0.3.ebuild
+++ b/app-text/binfind/binfind-0.0.3.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="Search files for a byte sequence specified on the command line"
HOMEPAGE="https://www.lith.at/binfind/"
@@ -10,4 +12,13 @@ SRC_URI="https://www.lith.at/binfind/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"
-IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf #870832
+}
diff --git a/app-text/binfind/files/binfind-0.0.3-clang16.patch b/app-text/binfind/files/binfind-0.0.3-clang16.patch
new file mode 100644
index 000000000000..12a7174ec0e9
--- /dev/null
+++ b/app-text/binfind/files/binfind-0.0.3-clang16.patch
@@ -0,0 +1,9 @@
+https://bugs.gentoo.org/870832
+--- a/configure.in
++++ b/configure.in
+@@ -26,4 +26,5 @@
+ [#include <stdio.h>
+ #include <stdlib.h>
++ #include <string.h>
+
+ int main(void)